Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Trusty (daily build) a couple days ago and, though overall I'm pleased, I've run into some problems running some standalone apps (not installed) that used to work just fine in 13.10 before the upgrade.

For instance, when I tried to run eclipse standard through the launcher, nothing happened. I tried to double click the executable, and nothing happened. When I attempted to run it the terminal, I got:

~ ❯❯❯ '/home/ecc/Apps/eclipseStandard/eclipse'
zsh: exec format error: /home/joaolopes/Apps/eclipseStandard/eclipse

This behavior is occuring to other apps, like Sublime Text 2 and other versions of eclipse. Do you have any ideia what's going on?

Edit to add: I'm using zsh and the file has the necessary perms.

share|improve this question

2 Answers 2

up vote 4 down vote accepted

Run

uname -m

and check if the programs you're trying to execute have the appropriate architecture. ie., 32 vs 64 bit.

share|improve this answer
1  
Seems like you're correct. I didn't notice I was running x86. Eclipse Standard x86 runs fine. Thanks. –  ecc Apr 14 at 16:35

Note that this error can also occur if, from within zsh, you attempt to directly execute an executable that has zero bytes (such as might happen when you accidentally truncate an executable shell script or never initialize it; by contrast, if you pass such a script as an argument to zsh, the error does not occur).

Observed on zsh 5.0.2.

Note that bash, ksh, dash do not exhibit this problem - they simply silently ignore such invocations.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.