Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've installed Ubuntu 13.10 and I'm trying to enter kiosk mode in chromium right on boot, but nothing is working.

I've been using this method (http://nexxylove.tumblr.com/post/22690398464/ubuntu-web-kiosk-in-10-easy-steps)

Create ~/.xsession, add the following;
#!/usr/bin/env bash
chromium-browser

Then when I'm running startx in terminal, it just refreshes the desktop and chromium doesn't pop up.

I've also tried the method with customized session:

1) Open a file (gksu gedit /usr/share/xsessions/Firefox.desktop) and paste:
[Desktop Entry]
Name=Firefox (No effects)
Comment=This session only opens Firefox
Exec=/usr/bin/firefox -height 1200 -width 1600
Icon=
Type=Application

But it doesn't work either. When I click on this file, chrome (I've changed the names) pops up. What am I doing wrong? I've spent almost 3 hours on this, trying to resolve it, followed many tutorials.


Ok, figured it out. I created /.xsessionrc instead of .xsession and now it works flawlessly.

share|improve this question
    
Ok I have something. When I use first method described above, go into console with ctrl+alt+f1 and then login to my kiosk user and run startx it goes into chromium browser with no problems. What can be the cause of this? – user268816 Apr 15 '14 at 9:27
    
Is there any reason you can't use the built-in startup manager for this? Also, you might be interested in the --kiosk flag for Chromium. – saiarcot895 Apr 16 '14 at 20:18
    
Startup manager wasn't working for me and I want to restrict user to only using browser. I'm using kiosk flag, just this script up here was simplified to just get it to work. – user268816 Apr 23 '14 at 5:31
    
I'm trying to do a similar thing. In my particular case I get an error: Xsession: unable to launch "/path/to/script argument" X session --- "/path/to/script argument" not found; falling back to default session. This tells me that Ubuntu is trying to find a file script\ argument at /path/to/, which is not what I want it to do. Strangely enough, I have it working without an argument, and gnome-session --session=ubuntu works as intended, but not not what I need. – MishaP Feb 17 '15 at 1:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.