Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I love this game, but when I type ClanBomber in Ubuntu Software center, it lists only Granatier. I probably need to add some repository?

share|improve this question
add comment

3 Answers

Granatier is advertised as "...a clone of the classic Bomberman game, inspired by the work of the Clanbomber clone"

ClanBomber looks like it was last "compiled" in a package (.deb) for Ubuntu Dapper. It is not recommended that you download such an old package and installing that - you could break stuff, even if it appears to work.

However, if you really must have the "original" - you will need to try one of two things.

Use the zeroinjector routine - step by step guide on the linked web-page below. The instructions refer to v9.04 of ubuntu, so I dont know if they will work on the current supported versions of ubuntu.

If the zeroinjector routine does not work you'll need to download the source-code and compile the source code.

Download the source code from here and use standard build instructions such as

sudo apt-get update
sudo apt-get install build-essential 
./configure
make
sudo make install
share|improve this answer
    
Thanks. But what then this package packages.ubuntu.com/dapper/clanbomber stands for? –  umpirsky May 23 '11 at 19:58
    
updated and clarified why you dont want to go down the dapper package route. –  fossfreedom May 23 '11 at 20:04
add comment

You can download Clanbomber from here: http://sourceforge.net/projects/clanbomber/

share|improve this answer
    
pastie.org/1963327 and getting DirectFB to work is hell blog.mageprojects.com/2009/05/12/…. I have tried by installing directfb-bin package, but I get same error. –  umpirsky May 23 '11 at 21:41
add comment
up vote 1 down vote accepted

After download in game folder:

sudo apt-get install build-essentials
sudo apt-get install libsdl1.2-dev
sudo apt-get install libsdl
sudo apt-get install libboost-all-dev
sudo apt-get install libsdl-image1.2-dev
sudo apt-get install libsdl-mixer1.2-dev
sudo apt-get install libsdl-ttf2.0-dev
sudo apt-get install libsdl-gfx1.2-dev
./configure
make
sudo make installl
sudo make install

Then run it with clanbomber2.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.