Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am being bothered by the strange screen fragment while using emacs.

Sometimes, when I edit something in emacs, the screen gets fragmented like this:

The lines are not correctly updated

enter image description here

Below is the correct display

enter image description here


My ubuntu is in VirtualBox. The VirtualBox version is 4.3.10. I have installed the guest addition.

The ubuntu I am using is

ubuntu 13.10
Intel® Core™ i7-2600 CPU @ 3.40GHz × 4
Chromium 64-bit

The emacs I am using should be the newest one

GNU Emacs 24.3.1 (x86_64-pc-linux-gnu, GTK+ Version 3.8.6) of 2014-01-03 on gold, modified by Debian

share|improve this question
    
Try adding this to your ~/.emacs file: ` (setq-default column-number-mode t)`. Does that help? –  terdon Apr 14 at 13:35
    
@terdon just did, let me use for a while and see whether it works. can you tell me what's the purpose of that setting? –  Jackson Tale Apr 14 at 14:09
    
Not really, no :) That's why this was just a comment. I had a similar, though not identical, problem and that helped. It is something to do with the number of columns your window has and seems to help with the drawing issues you describe. I believe the root of the problem is a miscommunication between emacs and the compositing window manager but I'm not sure. –  terdon Apr 14 at 14:12
    
@terdon sorry to tell ya that it didn't work. still I am having this issue –  Jackson Tale Apr 14 at 14:57
    
Yeah, that was just a wild shot in the dark. It improved but did not fix it for me too. Are you using unity or another desktop environment? –  terdon Apr 14 at 15:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.