Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to create a .dep package in my PPA. That project however requires a recent GCC 4.8 or Clang 3.4+.

I found out, that you can add custom PPA dependencies, so I added ubuntu-toolchain-r/test to it.

I also specified to require gcc >= 4.8 in the debian/control file via

Build-Depends: g++ (>=4.8)

However, the build bot complains as follows:

"g++: already installed (4:4.6.3-1ubuntu5 >= 4.8 is satisfied)"

and later, of course, my built fails, because it's not compiling with gcc 4.6 (precise).

So how can I convince him about my requirement ?

share|improve this question
    
Is it possible for you to give a link to your ppa? –  Sylvain Pineau Apr 14 at 7:32
    
Did you try with the exact ppa version gcc (>=4.8.1-2ubuntu1~12.04) ? –  Sylvain Pineau Apr 14 at 7:39
    
launchpad.net/~trapni/+archive/xzero - my goal (and problem) is to provide .dep's for 12.04 (basically anything that's not providing GCC >= 4.8). -- one sample failed build log: launchpadlibrarian.net/172753526/… –  trapni Apr 14 at 7:52
    
Actually, taking your second comment into account, it produces the following note in the (still failing build log): "g++: already installed (4:4.6.3-1ubuntu5 >= 4.8.1-2ubuntu1~12.04 is satisfied)". see: launchpadlibrarian.net/172777162/… –  trapni Apr 14 at 8:42
    
@trapni, could you please add/include important info from comments into question. so to be complete, and I can reference back to it later in similar problems. –  Sneetsher Apr 14 at 10:52

1 Answer 1

up vote 2 down vote accepted

You basically need to depend on g++-4.8:

Build-Depends: g++-4.8
share|improve this answer
    
I always stated g++ in my TP and comments. @Sylvain-pineau unfortunately used the term gcc, however, the issue remains the same. –  trapni Apr 14 at 8:52
    
and using g++-4.8 as a build dependency? –  Sylvain Pineau Apr 14 at 8:53
1  
Using just g++ does not work as it's a metapackage not available in the ubuntu-tooolchain ppa (Dependency wait in the builder). I've updated my answer to use g++-4.8 instead –  Sylvain Pineau Apr 14 at 8:58
    
Many thanks man. that's been it, I unfortunately cannot upvote it, but it was helpful indeed. –  trapni Apr 14 at 9:19
    
Cool, I up-voted your question, I should have notice the g++ instead of gcc earlier. –  Sylvain Pineau Apr 14 at 9:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.