Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recent support to XP has ended as a result I am looking for Linux driver for my Canon MF5550 which connects via USB. Could not find any driver for this printer for Linux. Need help how I can connect to my linux Box. Currently I am using Ubuntu 3.2.0-58-generic-pae.

Ubuntu is installed over VMware, for which I have changed it from local machine to Ubuntu via removal Devices option.

share|improve this question

1 Answer 1

Do you really need a driver, considering it is a plug and play USB Printer?

Ubuntu has native support for plug and play. Did you print something?

EDIT: Right click your virtual machine and select Edit Virtual Machine Settings.

Check for the Printer column. Press the Add button and go on configuring your printer through the Add Hardware Wizard.

Reboot your VM and try again.

And if this helps, please upvote.

share|improve this answer
    
I tried printing with the generic option, however task goes to spool and sits there. Option for MF5550 driver is not their, so I choose the generic one. It recognizes printer and throws an option for it but does not print. Ubuntu is installed over VMware, for which I have changed it from local machine to Ubuntu. sorry i forgot to add to the above topic. –  league0 Apr 14 at 2:31
    
You didn't see my edit? BUt if you say that VMWare does detect your printer, it's already configured. Try adding your printer again using the method I told you. If you have a LiveUSB with Ubuntu, boot it and try your edit again. –  Mayukh Nair Apr 14 at 13:36
    
Please check the following details, This is the message what I get when I disconnect printer from local host to connect to VM. connect (disconnect from local host) A USB device is about to be unplugged from the host and connected to this virtual machine. It will first be stopped to enable safe removal. With some devices, the host may display the message "The device can now safely be removed." –  league0 Apr 14 at 13:38
    
Once connected to Ubuntu On clicking printer ICOn in ubuntu - Add printer Click add printer select Device (Options to select from) Canon MF5550 (0455020100002253&interface#1) LPT#1 Enter URI Netwprk printer Once selected Canon MF5550 > it searches for additional drivers. 1.Choose drivers from database I see canon in this option not MF5550 make 2.Provide PPD file I tried inseting the CD which it directs wwould be the software, however could not find on it when the window pops 3.Search for printer driver to download This option when selecte keeps on serching and never ends –  league0 Apr 14 at 13:39
    
Printer is very much visible on Ubuntu, it is the relevant driver which is required.....please help and advice. –  league0 Apr 14 at 13:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.