Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The title says it all, really. I've recently moved to Ubuntu, tried a LOT of audio players, and I'm liking the features on Clementine so far but... It's the only program that isn't on English and it's an eyesore. Doesn't appear to have a language selection on the configuration window and web searches have been unfruitful so far, except for this: http://manpages.ubuntu.com/manpages/precise/man1/clementine.1.html but I have no idea as to where to input these commands so they're recognized.

Any help appreciated.

share|improve this question
    
How did you install it? What are your locale settings? I take it your Ubuntu is generally in English? –  terdon Apr 14 at 1:39
    
@terdon I installed Clementine through the Ubuntu Software Center. My Ubuntu and every program I installed so far are in English, except for my keyboard input method which is on "Spanish (eliminate dead keys)" to match the hardware. However the Clementine language localization seems to match the local use of Spanish where I live (Argentina), so I presume it's not using the keyboard input settings to set the language. As a quick test, changed the keyboard settings to English and the UI was still on "Argentinian Spanish". –  PsykoTenshi Apr 14 at 1:54
    
Can you please run the locale command and add the resulting output to the question. –  Gunnar Hjalmarsson Apr 14 at 2:05

2 Answers 2

up vote 1 down vote accepted

This looks like a bug in clementine or at least in the version that comes packaged with Ubuntu. I use it on my Debian and have not seen this before but I installed it today on a VM running Ubuntu and it appeared in French. I live in France but have absolutely nothing set to French on my system, much less the VM.

So, it looks like Clementine is assuming the language based on your IP or some other silly method. The good news is that there is a setting for that, at least on version 1.1.1 which is what is in the 13.10 repositories.

Just go into "Tools" => "Preferences" => "Behavior" and change the language:

enter image description here

share|improve this answer
    
Hey, many thanks. It appears I managed to miss that, I kept looking for a way to change the UI language in the User Interface section :rolleyes: Anyways, that did the trick, one less thing to worry about now :) –  PsykoTenshi Apr 14 at 2:34
1  
@terdon: Actually, if you run the locale command on that VM, you'll find that a few locale categories are set to French. Please see my answer. –  Gunnar Hjalmarsson Apr 14 at 2:41

I agree with terdon that the application is buggy, but it does check the locale, it's just that it checks the wrong locale category: LC_NUMERIC.

Now, the solution suggested by terdon is reasonably the best. Just wanted to show a way to workaround the bug:

$ cat ~/bin/clementine
#!/bin/sh
export LC_NUMERIC=$( printenv LANG )
exec /usr/bin/clementine "$@"

I simply put the file clementine in my ~/bin folder and set the executable bit (chmod +x).

share|improve this answer
    
Well I'll be, you're quite right. I guess that happens when I set the time zone to France during the installation process. Very nice, +1. You don't need the script though, you could just create an alias like this: alias clementine='LC_NUMERIC=$(printenv LANG) clementine'. Since they're on the same line, they're run in the same subshell and the export is not needed. –  terdon Apr 14 at 2:51
    
@terdon: Yes, the Ubuntu installer guesses the regional format settings based on time zone location. An alias works fine if you start the app from the shell, but what if you start it from the graphical environment by clicking an icon? –  Gunnar Hjalmarsson Apr 14 at 3:00
    
And you make a very good point again, the alias will indeed not work for icons. My main point was avoiding the export and exec calls by having LC_NUMERIC=$(printenv LANG) clementine on a single line but I'm just being pedantic. Thanks again for the info. –  terdon Apr 14 at 3:03
    
@terdon: You're welcome. I'm in a talking mood tonight. :) –  Gunnar Hjalmarsson Apr 14 at 3:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.