Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am encountering a very weird error recently, that I cannot figure out to solve...I have surfed for hours and hours without any solution.

I explain: I have an Asus S301L , with Ubuntu 12.04 and an Italian keyboard; every time I log in, some key on my keyboard does not work properly:

  1. p priduces *
  2. 0 produces /
    • produces +

But also others...for example, It took time for me to write just this message...so frustrating sometimes.

The only way to have things again to work properly is to type from a terminal:

setxkbmap it

That command takes a keyboard layout configuration from the folder

/usr/share/X11/xkb/symbols/

And it starts again to work, just for a (indefinite) duration of time , then, things, again, are wrong.

The output of the locale command is:

LANG=en_US.UTF-8
LANGUAGE=en_US:en
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=it_IT.UTF-8
LC_TIME=it_IT.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=it_IT.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=it_IT.UTF-8
LC_NAME=it_IT.UTF-8
LC_ADDRESS=it_IT.UTF-8
LC_TELEPHONE=it_IT.UTF-8
LC_MEASUREMENT=it_IT.UTF-8
LC_IDENTIFICATION=it_IT.UTF-8
LC_ALL=

I hope to be clear and have explained my problem.

Anyone can help me ?

Thanks in advance for all the answers you'll give me

Cheers G.

share|improve this question
    
Where are you setting your layout options? What desktop environment are you using? –  terdon Apr 13 at 17:35
    
The layout options are present in the folder /usr/share/X11/xkb/symbols/ and I use the Gnome DE. Thanks –  user2368158 Apr 14 at 6:22
    
I mean where do you set the layout? Do you use a terminal command (if so, which command, which file runs it etc) or do you use the Gnome settings? Please edit your questions and answer that and also include the output of the locale command. –  terdon Apr 14 at 13:12
    
I set my layout using the command setxkbmap it from terminal , this is the only one I use. I tryed to use the gnome settings, but nothing changed... –  user2368158 Apr 14 at 23:29
    
I also edited with the info you asked me... –  user2368158 Apr 14 at 23:39

1 Answer 1

What you describe sounds like the desktop environment (DE), Gnome in your case, is switching back to the default settings every now and then and that's what is screwing with your keyboard layout. The simplest solution would be to set the correct settings from the Gnome settings menu.

Open the System Settings, click on Keyboard, then on "Layout Settings":

enter image description here On the next screen, remove any keyboard layouts that you don't want:

enter image description here


If you still have this problem, you might want to also set the Regional Settings (System Settings => Language and Region) to whatever you prefer as well. However, I have always mixed US English layouts with European style number and regional settings so I doubt this is the issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.