Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've seen this asked multiple times here on AskUbuntu, but there are so many solutions and so diverse, that I don't know which one to try. I'm afraid I'll break something because I'm not very experienced with Ubuntu or Linux in general. If someone could point me to the correct solution, it would be awesome.

A bit of context:

  • I had Windows 7 already installed on my PC
  • I installed Ubuntu 13.10 alongside Windows, in dual-boot (not with Wubi)
  • After this, everything was fine, Ubuntu worked with no problems for about 2 - 3 months
  • But, when going into Windows, the checkdisk screen always appeared for some reason and I always skipped it
  • One time, a few days ago, I accidentally let checkdisk do its thing
  • After this, booting into Windows works fine. But booting into Ubuntu doesn't. I see the Ubuntu logo for 2 seconds and then the screen turns blank with only a blinking cursor in the top left.
  • PS: I didn't apply any updates in Ubuntu. From what I remember, I actually turned them off. So this shouldn't be the cause.

Like I said in the beggining: I don't want to try a ton of possible solutions and end up messing the whole boot mechanism and lose access to Windows as well. Based on the course of events mentioned in the bullet list, which solution should I try ?

Should I:

  • try changing quiet splash to no splash in GRUB like mentioned here ?
  • try finding and running some repair commands from the LiveCD ? (I still have the DVD, thankfully)
  • try running BootRepair ?

EDIT: The /var/log/boot.log file looks like this:

 * Starting mDNS/DNS-SD daemon [74G[ OK ]
 * Starting bluetooth daemon [74G[ OK ]
 * Starting configure network device [74G[ OK ]
 * Starting Uncomplicated firewall [74G[ OK ]
 * Starting configure network device security [74G[ OK ]
 * Starting Bridge file events into upstart [74G[ OK ]
 * Starting configure network device security [74G[ OK ]
 * Starting Mount network filesystems [74G[ OK ]
 * Starting Failsafe Boot Delay [74G[ OK ]
 * Stopping Mount network filesystems [74G[ OK ]
 * Stopping Failsafe Boot Delay [74G[ OK ]
 * Starting System V initialisation compatibility [74G[ OK ]
 * Starting modem connection manager [74G[ OK ]
 * Starting configure network device security [74G[ OK ]
 * Starting configure network device [74G[ OK ]
 * Starting network connection manager [74G[ OK ]
 * Starting CUPS printing spooler/server [74G[ OK ]
 * Starting userspace bootsplash [74G[ OK ]
Skipping profile in /etc/apparmor.d/disable: usr.bin.firefox
 * Starting cups-browsed - Bonjour remote printer browsing daemon [74G[ OK ]
 * Starting Send an event to indicate plymouth is up [74G[ OK ]
 * Stopping userspace bootsplash [74G[ OK ]
 * Starting Bridge socket events into upstart [74G[ OK ]
Skipping profile in /etc/apparmor.d/disable: usr.sbin.rsyslogd
 * Starting AppArmor profiles        [210G 
 [204G[ OK ]
 * Setting up X socket directories...        [210G 
 [204G[ OK ]
speech-dispatcher disabled; edit /etc/default/speech-dispatcher
saned disabled; edit /etc/default/saned
 * Restoring resolver state...        [210G 
 [204G[ OK ]
 * Stopping System V initialisation compatibility [74G[ OK ]
 * Starting System V runlevel compatibility [74G[ OK ]
 * Starting  [74G[ OK ]
 * Starting automatic crash report generation [74G[ OK ]
 * Starting  [74G[ OK ]
 * Starting regular background program processing daemon [74G[ OK ]
 * Starting ACPI daemon [74G[ OK ]
 * Starting anac(h)ronistic cron [74G[ OK ]
 * Starting  [74G[ OK ]
 * Starting  [74G[ OK ]
 * Starting save kernel messages [74G[ OK ]
 * Starting  [74G[ OK ]
 * Starting  [74G[ OK ]
 * Starting crash report submission daemon [74G[ OK ]
 * Starting CPU interrupts balancing daemon [74G[ OK ]
 * Stopping System V runlevel compatibility [74G[ OK ]
 * Stopping save kernel messages [74G[ OK ]

It doesn't really say much...

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Just remove the quiet splash from the GRUB cmdline. Now you should see text output which will also tell you whether there are errors on boot.

If it still stays blank, try Boot Repair

If you are getting lots of text, search for any errors shown there. Add these errors to your questions. This is best done by copying the boot logfile from within the Live System (from DVD).

  • Boot from DVD
  • For you're not very experienced with Ubuntu, I'll show you the GUI way to do it:
  • Open the file manager
  • Go to the Ubuntu partition (Should be listed on the left)
  • If you're not sure which is Windows and which is Ubuntu (as long as they aren't labelled), try both. The Ubuntu partition got directories like etc, usr, home int it, Windows doesn't
  • Go to <UbuntuPartiton>/var/log and open the file boot.log.

Add the contents of this file to your question (edit it and insert the stuff formatted as code: Select the inserted log and hit Ctrl+K)

With this information we might help you better.

share|improve this answer
    
I just replaced quiet splash with no splash and then it just worked. Thank you for your answer. I did add the contents of /var/log/boot.log to my question, but it doesn't really say anything useful. Besides, problem solved anyway. Thank you. –  Radu Murzea Apr 13 at 12:03
    
Thats weird... Remember to also put the no splash in /etc/default/grub so it's kept when the GRUB configuration is updated. (Run sudo update-grub2 afterwards) –  the_Seppi Apr 13 at 12:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.