Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After I upgraded to 13.10 an ugly white icon theme appeared at top panel of lightdm, which does not fit bluish theme. I am using zorin greeter. I also tried gtk greeter but I didn't like it.

I took a pic of current lightdm theme using lightdm --test-mode enter image description here

Above picture doesn't reflect actual appearance, icons full of white corners.

How can I replace my own icon sets with above icons?

EDIT: there is also no power button option at top right bar. Did latest lightdm drop some features?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

As a reference to myself in the future, I fixed it like that:

I switched to unity-greeter and run

sudo xhost +SI:localuser:lightdm
sudo su lightdm -s /bin/bash
gsettings set com.canonical.unity-greeter icon-theme-name ubuntu-mono-dark

And I have a nice icon set.

share|improve this answer

You can use Ubuntu Tweak, it has an option to set the lightdm gtk and icon theme.

To install it:

sudo add-apt-repository ppa:tualatrix/ppa sudo apt-get update sudo apt-get install ubuntu-tweak

enter image description here

You'll find the options in the Tweaks sections (since changing themes for the login screen requires root privileges, you'll need to unblock it).

Also, in another section you can set the wallpaper (manually, or set it to use the same your user has as default).

share|improve this answer
    
I applied your guide and rebooted. Unfortunately it didn't work. –  kenn Apr 13 at 9:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.