Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

trying to install this, I am getting the 'Unable to correct problems, you have held broken packages' error message.

Apache version

Server version: Apache/2.4.2 (Ubuntu) Server built: Jun 27 2012 07:23:35

# aptitude install libapache2-mod-wsgi

The following NEW packages will be installed:
  apache2.2-common{ab} libapache2-mod-wsgi
 0 packages upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 299 kB of archives. After unpacking 1,047 kB will be used.
The following packages have unmet dependencies:
 apache2 : Conflicts: apache2.2-common but 2.2.22-1ubuntu1.5 is to be installed.
 apache2.2-common : Depends: apache2.2-bin (= 2.2.22-1ubuntu1.5) but it is not going to     be installed.
                Depends: apache2-utils but it is not going to be installed.
 apache2-bin : Conflicts: apache2.2-common but 2.2.22-1ubuntu1.5 is to be installed.
 apache2-data : Conflicts: apache2.2-common but 2.2.22-1ubuntu1.5 is to be installed.
The following actions will resolve these dependencies:

 Keep the following packages at their current version:
1)     apache2.2-common [Not Installed]
2)     libapache2-mod-wsgi [Not Installed]


Accept this solution? [Y/n/q/?] Y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

Any help appretiated

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.