Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I log in, my second monitor is "off" by default; Ubuntu acts as if it's not connected. I can enable it by going to System Settings -> Displays and flipping the OFF switch to ON, but I'd rather not do this every time I start up.

I don't know enough about my system to give more detail, but I can run whatever commands you think would be helpful.

Full steps to reproduce:

  1. With laptop off, connect second monitor by VGA.
  2. Turn on laptop.
  3. Log in at the login screen. (At the login screen, the second monitor mirrors my laptop.)
  4. Wait for the login to complete. While waiting for login to complete, I see the following behavior, in order:
    • The second monitor acts correctly and no longer mirrors. This lasts for a few seconds. Both screens show my wallpaper.
    • Second monitor no longer detected. My laptop has a black background.
    • Login complete. I can see the launcher and my terminal, but the second monitor is black.

EDIT:

To add more information, this is Ubuntu 12.04 LTS on a VAIO Z series laptop with an Acer monitor. I haven't found this particular problem described anywhere, so I haven't tried anything yet.

Data of interest:

share|improve this question
    
To debug your issue please add to your question (using pastebin.ubuntu.com) the output of lspci and the content of your /var/log/Xorg.0.log –  Sylvain Pineau Apr 12 at 20:12
    
I've updated the original post with links to my lspci and Xorg.0.log output. –  akp Apr 12 at 21:22
    
Since you have an nvidia discrete card, I'd suggest to use nvidia-settings to manage/save the display configuration. –  Sylvain Pineau Apr 12 at 21:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.