Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I am running the latest stable version of Transmission (version 2.31 from the Transmission ppa). Any time I try to log in to the web user interface, I get hit with this:

409: Conflict

Your request had an invalid session-id header.

To fix this, follow these steps:

When reading a response, get its X-Transmission-Session-Id header and remember it Add the updated header to your outgoing requests When you get this 409 error message, resend your request with the updated header This requirement has been added to help prevent CSRF attacks.

X-Transmission-Session-Id: CBcYiodnQIHKYkhr9EceZOMW3ICgMSgt6j2FTCOXbcunA1tK

Anyway, I've had this problem with Transmission for the last couple of versions, and I haven't been able to find an answer as to how to fix this anywhere online. If anyone has any ideas, let me know.

share|improve this question

3 Answers 3

What is the URL you're trying to use?

Don't forget the trailing slash http://host:9091/transmission/web/ (it makes all the difference)

share|improve this answer
I don't even have apache installed. In the past, I didn't need to install or tinker with apache at all to get the webui to work. Also, I'm using URL format host:9091/transmission/web – Ken May 25 '11 at 10:52
sorry, misunderstood. Updated answer. – hometoast May 25 '11 at 14:28
Omg, why the trailing slash is so important? I can't beleave that this resolved the problem. – KoCMoHaBTa Apr 27 at 5:31

Try adding #files to the end of the address. e.g /web/#files.

It worked for me.

I was even able to take the #files off it once I had logged in and it still worked for some strange reason?

share|improve this answer

fwiw, I read the comment about the slash above and I am using the ttransmission remote gui.

I recentely added far more than my usual number of torrents to a seedbox and started reciving the session ID error and timeout errors as well in the client.

I was, however, able to access the web interface fine (it was just slow). I fixed the remote gui client by locating the URL in the settings and appending a / to the end of /transmission/rpc, so that I had /transmission/rpc/

this made it work normally except for the occasional timeout issues which i think has less to do with a setting and more to do with the sheer load (although it's only pushing 10mb/sec on gigabit down and 5mb/sec up (though that's just my portion if this is a shared box)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.