Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have this little MAAS with only one node ready to deploy (ubuntu 12.04 Precise pangolin)... I was trying to set up the Juju enviroment but i continously get this error

$ juju bootstrap 
Bootstrap failed, destroying environment 
ERROR Bootstrap failed, and the environment could not be destroyed: gomaasapi:got      error back from server: 401 UNAUTHORIZED (Invalid consumer.) 
ERROR could not access file 'a576cc0e-bf67-4b7c-8c22-eacb51826eaf-provider-    state':     gomaasapi: got error back from server: 401 UNAUTHORIZED (Invalid consumer.)

I tried changing the API key to a fresh one from MAAS but i didn't help, actually i got the same error code.

I am communicating throught an ssh connection over a vpn from win7 with Putty, the server and my host are autenthicated throught rsa key, i tried to change the enviroment.yaml but to my eyes it seems all correct.

Does anybody know what's wrong?

share|improve this question

1 Answer 1

401 is essentially letting you know you're credentials are not clearing at the MAAS level. Make sure your SSH key from both machines are enlisted in MAAS, and that you removed ~/.juju/environments/maas.jenv from your machine as it caches information.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.