Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my office,proxy is enabled in my system .When i use wget for downloading,The terminal giving "No route to host" issue.But when i connect to the same site using browser,It is connecting.I've configured the proxy settings in my browser.Seems like I have to do some setting in my system.
Pls help

share|improve this question

1 Answer 1

up vote 1 down vote accepted

For wget to work, you need to set http_proxy and https_proxy environment variables. E.g.:

export http_proxy="http://proxyhost:8080/"
export https_proxy="http://proxyhost:8080/"

You can check what values are set by executing:

echo $http_proxy

Generally, it is better to set your browser to "Use system proxy settings" and then configure proxy under "System -> Preferences -> Network Proxy" (and apply system-wide). This sets proxy settings in various places. However, I'm not sure if this configures above mentioned environment variables as well.

share|improve this answer
    
K thats worked.. –  Abdul Shajin May 23 '11 at 14:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.