Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a ubuntu 13.10 desktop setup with a samba server. Users can access their assigned folders from their Windows 7 workstation, but they can also see other folders that they don't have permissions to open the folders. I've already tried using "hide unreadable = yes" as well as modifying "browseable = no", but the folders are still visible.

Also I always have to restart the whole system in order settings changes in Samba to take affect. I've already to stop, start and restart Samba server. Is there a way to avoid restarting the whole system?

I've also tried adding "hide unreadable = yes" under global settings.

Attached is the smb.conf file:

http://s29.postimg.org/tkw1jagxz/pic.png

[fdipice]
    path = /home/BU/Users/fdipice
    writeable = yes
;   browseable = no
    hide unreadable = yes
    valid users = fdipace
    comment = Frank's Home Directory

[jkoan]
    path = /home/BU/Users/jkoan
    writeable = yes
;   browseable = no
    hide unreadable = yes
    valid users = jkean
    comment = 

[tim]
    path = /home/PU/Users/tim
    writeable = yes
;   browseable = no
    hide unreadable = yes
    valid users = tim
    comment = 

[IT_software]
    path = /home/PU/Shared/IT_software
    writeable = yes
;   browseable = no
    hide unreadable = yes
    valid users = john
    comment = IT shared folder
share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.