Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have nvidia gtx280. Using the 10.10 version I had no problem with it.
But at 11.04 I keep getting the "This driver is activated but not currently in use" message.

Output of /usr/lib/nux/unity_support_test -p:

Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes
Unity supported: yes

Also, all the effects of the windows have gone. I have found out that with compizconfig settings manager I can enable-some effects but after I do that the top panel sometimes vanishes or even the launcher.

Tried installing the simple compizconfig settings manager, I get this:

Package dependencies cannot be resolved
This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.

When I click on "Details" I get this:

The following packets have unresolved dependencies:

Additional drivers

Also, from the nvidia x server settings:

System Information: Linux-x86_64
NVIDIA Driver Version: 270.41.06

I checked at the nvidia site and saw that they have released an updated version of the driver. Version is: 270.41.19. I have downloaded a RUN file, how can I install it?

What can I do?

Screenshot from additional drivers app:

Also, from the nvidia x server settings:

System Information: Linux-x86_64
NVIDIA Driver Version: 270.41.06

I checked at the nvidia site and saw that they have released an updated version of the driver. Version is: 270.41.19. I have downloaded a RUN file. How can I install it? (I am new to Ubuntu OS :S)

Also if it is wrong that I have bumped my question please advise me what can I do so that I can add these extra info about my problem.

share|improve this question
This may be bug#772207 – Takkat May 23 '11 at 10:04
How can I confirm that this is the bug? Also, should I reply there and report my GPU? Thank you! – Chris May 23 '11 at 11:14
@chris did you get this solved? – Rinzwind Feb 23 '12 at 18:58
@Rinzwind: I installed ubuntu 11.10 and it seems to be working fine! – Chris Feb 25 '12 at 22:13

Prior to Natty I was using the latest proprietary Nvidia driver, using the default Nvidia installation program. However, upon upgrading from 10.10 to 11.04 (did not do a fresh install), I began using the 'nvidia-current' package. In the past I had blacklisted 'nouveau' and I had to reinstall 'nvidia-current' before things would function correctly.

I apologize for the disjointed response. I guess I am asking if you are using the 'nvidia-current' package to deliver your video driver. If this is the case, have you tried reinstalling the package?

share|improve this answer
This is what I see at the additional drivers: I should have posted it the time I asked my question. – Chris May 24 '11 at 9:48
Yeah, this is what I saw before I did a reinstall of the Ubuntu nvidia-current package. It was on my system, but gave me the same results you are seeing. I opened Synaptic and marked the package to be reinstalled. After that, and a reboot, everything worked fine for me. – Kory Wnuk May 27 '11 at 16:09
Sorry for the delayed answer.How did you do the reinstall of the Ubuntu nvidia-current package? Thank you for your reply! :) – Chris Jun 12 '11 at 11:50
From the 'Control Center', I fired up the 'Synaptic Package Manager'. Once in Synaptic, search for Nvidia. Then right mouse click on 'nvidia-current' and choose to have the package reinstalled, or if it is not installed, choose to install it. – Kory Wnuk Jun 12 '11 at 17:07

Relative to installing from the downloaded RUN file, I generally will switch into a TTY with:


Then you need to kill the X instance. For this I look for the 'gdm-binary', for example:

ps ax | grep gdm

Once I have the PID, I use:

kill -9 XXXXX

The 'XXXXX' is the PID I identified. Once X has been terminated, I execute the RUN file.

sudo sh ./NIVIDIA-whatever-the-rest-of-the-file-name-is

From here it is a matter of reading the screens and responding to them. Generally speaking, I do not let the installer monkey around with Xorg.conf.

share|improve this answer

Happened to me with series 8 integrated NVIDIA hardware after a fresh install of 11.04. Only thing I could do to make things work is use the expermental 3D open source diver which seems to work very well for compiz gears and games. Odd Unity would run fine with the NVIDIA current which supposedly needs 3D support and some compiz settings would work. gears would turn realy realy slow. I hope it iss fixed for me in next release on the other hand if an open source driver wwork for me thats great. Some also saaid the wrong current verssion is in the repository it should be 270.41.06 .

Some info:

Did you do a: sudo nvidia-xconfig on the command-line may be necessary before the driver module will function. This did not fixx mine

share|improve this answer
also check this… – stevehendo34 Aug 18 '11 at 7:08

Also check /var/log/kern.log for:

error starting driver vmap allocation for size 16781312 failed: use vmalloc= to increase size

  1. Edit the line GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub.
  2. Add the option: vmalloc=192MB so it will look like:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vmalloc=192MB"
  3. Update the bootloader configuration afterwards:

    sudo update-grub
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.