Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday I've tried to install Ubuntu on my windows 7 desktop pc. I've burned the iso on a dvd, and installed the help boot. Then it asked to reboot, after that it took me to the ubuntu purple screen and it went smooth, I could try the features of ubuntu, entered Mozilla and everything. But when I put install Ubuntu 13.10 (inside of Ubuntu interface), guided me through the steps. But since I couldn't see the guided installation on the ubuntu website, I forgot to check 'install third party apps' or something like that. So when I finally put 'Install', an error message pop up "Error informing the kernel about modifications to partition /dev/sda2 - Device or resource busy. This means that Linux won't know about any changes you made to /dev/sda2 until you reboot - so you shouldn't mount it or use it in any way before rebooting" I tried to click Ignore, cancel, close it. But it did nothing, behind this message, was the location map. The rest of the ubuntu interface worked just fine, except I couldn't go back to windows or close that error message. So I rebooted, after the startup screen (not the windows one), it went black screen with flashing/intermitent white dash. Just that. I can't do anything else in there but rebooting. I'm new in all of this and I'm starting to regret installing ubuntu at all. From what I've tried, I can access BIOS, but then I'm completely lost.

Please help me T.T I would just like to go back to windows if the ubuntu fix it's too complicated u.u

share|improve this question
    
Welcome to AskUbuntu! The details of the error message would come quite handy to help you. If you remember them, please edit your question. –  the_Seppi Apr 11 at 16:36
    
I changed it now, the full error message. Luckily I screenshooted before everything went wrong u.u –  user267876 Apr 12 at 0:31

1 Answer 1

Are you still able to boot the Ubuntu DVD?

If yes, select Try Ubuntu and, after getting to the Desktop, press Ctrl+Alt+T to open a terminal.

Now enter cat /var/log/boot.log and tell whether any errors are listed there. Also search cat /var/log/kern.log for errors.


If this experience scared you away from Linux and you just want to go back to Windows, open the program GParted and set a boot flag to your Windows partition. Remove the boot flag from the Ubuntu partition. Now try to reboot.

If you can reboot into Windows, and want to remove Ubuntu, just reboot to the Ubuntu DVD, open GParted and delete the Ubuntu partiton and the SWAP partition.

Resize the Windows partition to use the new free space to get the space usable again. NOTE: Before doing this, have a backup of your personal data from Windows, because partitioning can always cause problems.


To all the Moderators: I know this doesn't answer the original question, but I'm going to add additional instructions when I know more about the prob and am able to help.

share|improve this answer
    
No, I can't boot anything at all. I've tried to boot with the ubuntu dvd and just in case with the windows one, nothing happens. Apart from that I can't access windows or ubuntu's interface to do what you explained. It just stays forever on that black screen, but before that, the startup screen appears and that's when I can access BIOS. Otherwise, I'm stucked there. Is there any possibility to do something from the BIOS? –  user267876 Apr 11 at 20:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.