Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been using mariadb for a while on Ubuntu 12.04 with an ODBC DSN that I could use in R.

Today it stopped working and I've been checking things like reinstalling packages, moving to mariadb 10 (as an issue which prevented ODBC connections has been fixed), and generally looking around.

I am unfortunately still getting the following error

slocke@host:~$ isql -v myDB
Floating point exception (core dumped)

Can folks advise on a) how to debug further and /or b) what the likely issue is?


UPDATE 1 Further to @Rinzwind's suggestion and this SO question I was able to locate a crash report / core dump. Using apport-retrace I have tried to open both isql .crash files present in the /var/crash directory however both get the following error

sudo apport-retrace -g -R  /var/crash/_usr_bin_isql.0.crash
Program terminated with signal 8, Arithmetic exception.
#0  0x00007ff459929366 in sqlchar_as_sqlwchar () 
from /usr/lib/x86_64-linux-gnu/odbc/libmyodbc.so

UPDATE 2 Based on the error message, it looks like a known bug with the MySQL ODBC connector. It has subsequently been fixed, however, the version it has been fixed in is not available in the Ubuntu repository. I've attempted to download and install a later version but installing it seems very difficult (to me!) with dependencies that can't be met by the repository and a complete lack of installation instructions for Ubuntu in the INSTALL file.


ODBC config

/etc/odbcinst.ini

[MySQL]
Description     = ODBC Driver for MySQL
Driver          = /usr/lib/x86_64-linux-gnu/odbc/libmyodbc.so
Setup           = /usr/lib/x86_64-linux-gnu/odbc/libodbcmyS.so
FileUsage       = 1

/etc/odbc.ini

[myDB]
Description = Database linked to application
Driver = MySQL
SERVER = localhost
USER = abc
PASSWORD = mypwd
PORT = 3306
DATABASE = mydb

Installed mariadb packages

 dpkg --list


ii  mariadb-client 10.0.10+maria- MariaDB database client binaries
ii  mariadb-client 10.0.10+maria- MariaDB database core client binaries
ii  mariadb-common 10.0.10+maria- MariaDB database common files (e.g. /etc/mys
ii  mariadb-server 10.0.10+maria- MariaDB database server (metapackage dependi
ii  mariadb-server 10.0.10+maria- MariaDB database server binaries
ii  mariadb-server 10.0.10+maria- MariaDB database core server files

Other packages

ii  libmyodbc      5.1.10-1       the MySQL ODBC driver
ii  libmysqlclient 10.0.10+maria- Virtual package to satisfy external depends
external depends

ii  unixodbc       2.2.14p2-5ubun Basic ODBC tools
ii  unixodbc-dev   2.2.14p2-5ubun ODBC libraries for UNIX (development files)
share|improve this question

closed as off-topic by bain, Eric Carvalho, LnxSlck, belacq, Radu Rădeanu Jul 11 at 23:51

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – bain, Eric Carvalho, LnxSlck, belacq, Radu Rădeanu
If this question can be reworded to fit the rules in the help center, please edit the question.

    
That core dump... did you track that down? gdb can be used to view it. Maybe that will narrow down where the problem is. –  Rinzwind Apr 14 at 8:14
    
I'm a database person from a Microsoft background so my use of Linux is somewhat limited. I read through the man page and arrived at the conclusion I should be running a command like gdb isql myDB but it told me there were no debugging symbols - not sure how to proceed further on that front –  Steph Locke Apr 14 at 8:16
    
Oh that message "core dumped" means that the "memory state" is save on disc when the segmentation fault happend. Sometimes it can be used to find out what tried to read in memory where it should not. –  Rinzwind Apr 14 at 8:42
    
Hi @Rinzwind, looks like I was able to go to get out some sort of meaningful error (to someone anyway!) from apport-retrace thanks to you –  Steph Locke Apr 14 at 9:21
    
Do you need to use isql? (1st time I see that so I had to look it up :D ). It could be a bug in isql. Most will use workbench (not webbased) or phpmyadmin (webbased). –  Rinzwind Apr 14 at 9:39

Browse other questions tagged or ask your own question.