Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have trawled through a multitude of questions regarding this problem, tried many of the given solutions and still the problem persists.

Ethernet works fine but wireless is stuck in a loop trying to connect to my router with the security prompt popping every so often to ask me for the wireless key (which has been entered correctly)

Help would be greatly appreciated :)

edit > result of lspci -nnk | grep -A2 Net:

08:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
    Subsystem: Dell Wireless 1397 WLAN Mini-Card [1028:000c]
    Kernel driver in use: wl

yes driver has been installed and activated from Additional Drivers

share|improve this question
    
Four lines of text+no punctuation=hard to read. Anyway, we'll need more info from you, please add the output of lspci -nnk | grep -A2 Net to the question. –  mikewhatever Apr 11 at 12:59
    
Did you install the Broadcom proprietary drivers for your chip? –  Sylvain Pineau Apr 11 at 13:03
    
Added result of your given command. Will try to punctuate correctly from now on. –  Ragedy Sam Apr 11 at 13:20
    
I have installed the driver. –  Ragedy Sam Apr 11 at 13:20
    
OK, seems to have solved itself when I deleted the wireless network that was saved in my connections, and started afresh. –  Ragedy Sam Apr 11 at 13:50

1 Answer 1

Try this:

sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source
sudo apt-get update
sudo apt-get install b43-fwcutter firmware-b43-installer
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.