Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Artha Dictionary, and all I want to do is hide its icon from the notification area without loosing its functionality (i.e. Ctrl+W to bring up the meaning of selected word and show the same using NotifyOSD.). The only reason why I want to do it is, Artha's icon is not monochrome and hence doesn't integrate well with rest of the icons showing in the panel.

The Panel showing Artha's icon and other icons.

While using Unity, the icon is not shown and I still get proper notifications of word meanings I look up, the icon appears on panel in the classic mode. Removing Notification Area from the panel also removes Artha's functionality. If icon cannot be hidden, I'll prefer to have a monochrome icon for Artha that looks perfect on panel.

share|improve this question
    
The latest version of Artha 1.0.3 has the option of hiding the status bar/system tray icon. You can install it via the PPA launchpad.net/~legends2k/+archive/artha :) –  legends2k Oct 8 '12 at 10:58
add comment

3 Answers

up vote 3 down vote accepted
  1. Open usr/share/pixmaps/artha.png in an image editor.
  2. a) To make it dissapear: Resize the icon to 1 pixel in width and paint it transparent.

    b) To change the icon: Paste any image you want over the top of the existing image.

  3. Save the image to the Desktop.
  4. Open Accessories;Terminal and enter the following command replacing zach with your own home folders name:

sudo mv '/home/zach/Desktop/artha.png' '/usr/share/pixmaps'

The changes should take effect upon restarting your computer.

share|improve this answer
add comment

Here is what I did.

Go to /usr/share/pixmaps.

Rename 'artha.png' to 'artha1.png'

Now you get this on start:

WARNING : Error loading icon file!
/usr/share/pixmaps/artha.png not found!

If you lose the icon in the menu after doing this:

Go to /usr/share/applications and change the icon manually for Artha to /usr/share/pixmaps/artha1.png (usually with right click- Properties).

I hope in the next update a feature to hide tray icon is included. (Currently v1.0.2.)

share|improve this answer
add comment

While using Unity, the icon is not shown and I still get proper notifications of word meanings I look up, the icon appears on panel in the classic mode.

To enable this, I suggest that you do the following:

sudo apt-get install dconf-tools

Type Alt-F2 and enter "dconf-editor"

Navigate to:

(Ubuntu 11.04) desktop -> unity -> panel

(Ubuntu 12.10) com -> canonical -> unity -> panel

Add 'artha' to the systray-whitelist, thus:

['JavaEmbeddedFrame', 'Mumble', 'Wine', 'Skype', 'hp-systray', 'scp-dbus-service', 'artha']

...and save it.

The artha icon should now appear on the "panel" or "notification area" (completely close Artha and re-open it).

share|improve this answer
    
I guess adding to white-list will make it appear, and I DON'T want it to appear. –  Kush Jun 5 '11 at 2:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.