Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying install python library pandas on ubuntu system, and it seems to work, but it it does not. Here is what I did:

sudo pip install pandas

This seemed to install pandas properly. I got this message:

Successfully installed pandas python-dateutil pytz numpy six
Cleaning up...

However, when I ran:

pip freeze

I did not see pandas installed. Also, when I tried to import pandas in python shell in I couldn't (obviously).

Any ideas what is going wrong? Or what I could do to trouble shoot, and figure out what is going?

I am using ubuntu 12.04.

Thank You

share|improve this question
    
Have you activate a virtualenv when running these commands? –  OrangeTux Apr 10 at 16:49
    
@OrangeTux, I am in the virtualenv when running these commands. –  Akavall Apr 10 at 16:59

1 Answer 1

up vote 2 down vote accepted

When you use sudo pip install pandas (with sudo) you use the system wide binary of pip. It is probably located /usr/bin/pip. You should activate your virtualenv and run pip install pandas, without sudo. Than you use the pip binary of your virtualenv. Now pip freeze will give the expected results.

share|improve this answer
    
That solved my problem. Thank you very much! –  Akavall Apr 10 at 17:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.