Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to connect an old HP LaserJet 1000 printer on a new Windows machine. The printer hasn't had any new drivers since XP. I found a solution online with this recommendation but I'm getting bogged down in details. I am a complete novice to this.

I've installed Ubuntu Server 10.04 on VirtualBox. During the installation of Ubuntu, I selected Print Server for software selection. I have also subsequently installed foo2zjs and cups from the OS. I took the IPv4 address for the VirtualBox by running ipconfig in the Windows command prompt; I added this address to /etc/cups/cupsd.conf:

Listen 192.168.56.1:631

I have also alternatively omitted the above line and left the original "Port 631" line. I have always left the "Listen /var/run/cups/cups.sock" line.

I also changed all of the "Allow @LOCAL" lines in the three Locations to "Allow all".

I then re-started the CUPS server with sudo /etc/init.d/cups restart.

When I open a browser on the Windows machine, I can't connect to the CUPS web interface. I've tried the following:

192.168.56.1:631
localhost:631
localhost:631/admin
lj1000-server:631

I also tried using the inet address 10.0.2.15 listed from ifconfig from the Ubuntu terminal prompt instead of the 192.168.56.1 listed for the VirtualBox. Any suggestions on what I'm missing?

[Edit:] I have now also forwarded port 631 on my router for IP address 192.168.56.1 as well as adding Inbound and Outbound rules on Windows Firewall to allow connections with Protocol type TCP on Local/Remote ports 631 on Local/Remote IP address 192.168.56.1. Still nothing yet.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.