Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been trying to get Ubuntu 13.10 & Windows 8.1 to boot together. I installed Ubuntu on my main hard drive (which came with Windows pre-installed). However, when I tried to boot Ubuntu, it just skips to Windows. I've looked through numerous questions, answers & forums and none of them have helped me.

When I load Windows, everything is fine but when I load Ubuntu, I get this error:

error: file `/boot/grub/i386-pc/normal.mod` not found
Entering rescue mode...

The first thing I did was run boot-repair but that did nothing. Part way through boot-repair a dialog box appeared saying:

WinEFI detected. Backup and rename WinEFI files? Yes or no? (or something like that)

Is that my problem? I've tried both ways with no luck.

I have tried this on both UEFI and Legacy mode and both yield the same results. I have also tried toggling Secure Boot but this again seems to do nothing.

Here is the paste from after boot-repair (the last one I did): http://paste.ubuntu.com/7227403

Can anybody help me? This is getting really frustrating. Thanks in advance.

share|improve this question
    
I don't know what the cause of this is. But you should use a 64bit Ubuntu and you should disable Windows' fast boot if you want to be able to use the NTFS filesystems in Ubuntu. As long as you don't shutdown Windows properly, you'll have problems with its filesystems. –  Jo-Erlend Schinstad Apr 9 at 19:35
    
    
Often that error is from booting an UEFI system in BIOS mode. It looks like you have grub in gpt's protective MBR for BIOS boot, but have reinstalled or Boot-Repair converted to UEFI boot. You must boot with UEFI mode, not BIOS/CSM/Legacy mode. –  oldfred Apr 9 at 20:35
    
    
I've looked through these questions already and they don't fix my problem. –  Cameron Brown Apr 10 at 13:03
add comment

1 Answer 1

up vote 0 down vote accepted

Locate the partition in which linux is present with the help of following technique

grub rescue > ls (hd0) (hd0, msdos9)....(instead of 'msdos',it may be 'gpt' in your case)

grub rescue > ls (hd0,msdos9)

grub rescue > ls (hd0,msdos8)

grub rescue > ls (hd0,msdos5) # suppose this is linux

grub rescue > ls (hd0,msdos5)

grub rescue > set root=(hd0,msdos5)

grub rescue > set prefix=(hd0,msdos5)/boot/grub

grub rescue > insmod normal

grub rescue > normal

Now, system's boot menu appears. Boot into linux.

sudo update-grub

sudo grub-install  /dev/sda # If the drive is hd0 the equivalent is sda, if it's hd1 then use sdb

This fixes boot loader.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.