Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't login to my vsftpd server - I am getting error 530 Login incorrect. How to fix it?

/etc/vsftpd.conf

listen=YES
anonymous_enable=NO
local_enable=YES
write_enable=YES

dirmessage_enable=YES
use_localtime=YES
xferlog_enable=YES
connect_from_port_20=YES
chroot_local_user=NO
secure_chroot_dir=/var/run/vsftpd/empty

# I tried both...
#pam_service_name=ftp
pam_service_name=vsftpd

rsa_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
rsa_private_key_file=/etc/ssl/private/ssl-cert-snakeoil.key

seccomp_sandbox=NO

/etc/pam.d/vsftpd

# Standard behaviour for ftpd(8).
auth    required    pam_listfile.so item=user sense=deny file=/etc/ftpusers onerr=succeed

# Note: vsftpd handles anonymous logins on its own. Do not enable pam_ftp.so.

# Standard pam includes
@include common-account
@include common-session
@include common-auth
auth    required    pam_shells.so

/etc/ftpusers

# /etc/ftpusers: list of users disallowed FTP access. See ftpusers(5).

# commented 'root' for tests. can't login either
#root
daemon
bin
sys
sync
games
man
lp
mail
news
uucp
nobody

/etc/shells

# /etc/shells: valid login shells
/bin/sh
/bin/dash
/bin/bash
/bin/rbash

/var/log/vsftpd.log

...
Wed Apr  9 16:49:07 2014 [pid 9838] CONNECT: Client "127.0.0.1"
Wed Apr  9 16:49:09 2014 [pid 9837] [my-username] FAIL LOGIN: Client "127.0.0.1"

$ groups

my-username adm cdrom sudo dip plugdev fuse lpadmin sambashare ftp

$ id my-username

uid=1000(my-username) gid=1000(my-username) groups=4(adm),24(cdrom),27(sudo),30(dip),46(plugdev),104(fuse),108(lpadmin),124(sambashare),129(ftp),1000(my-username)

I tried to change pam_service_name, added seccomp_sandbox=NO, I reinstalled vsftpd, I tried dpkg-reconfingure (I restarted vsftpd service after every config change). Still no success...

Obviously user my-username exists, and it's in ftp group as above.

How to make vsftpd works?

I haven't use vsftpd for some time and it stopped working after some update. I am using xubuntu 13.10

Edit: just tried same settings on different computer (fresh xubuntu install) and it works OK. what am I missing?

Currently I am just using pure-ftp...

share|improve this question
    
Any reason you are using traditional ftp over sftp? Not a constructive comment. Just curious really. –  Petey T Apr 16 at 22:19
    
@PeteyT it's complicated :] –  Peter Apr 17 at 8:20

1 Answer 1

Check this link: http://senthilthoppur.blogspot.com/2012/08/vsftpd-530-permission-denied-root.html

You can try adding "userlist_deny=" in the "/etc/vsftpd/vsftpd.conf" file.

If "userlist_deny=NO", it will only allow users in the file "/etc/vsftpd/user_list".

You can also refer to : http://arstechnica.com/civis/viewtopic.php?t=112812

share|improve this answer
    
didn't work. i think it's not about permissions, it's like vsftpd have no users list? –  Peter Apr 22 at 10:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.