Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Nautilus when trying to share a folder that is owned by me, i can not share it without a password (Guest Access) as seen on the image. I already installed the samba service that was needed. What could it be?

enter image description here

share|improve this question

2 Answers 2

I don't have a definitive answer for you, but I thought I'd link to a similar question I asked a while back. There were many informative answers and there is a lot of good samba-related information in that thread: No access to Samba shares

I feel your pain, sir. I still haven't got Samba to work satisfactorily. I just gave up and use sshfs now.

share|improve this answer
    
i find it strange since in 10.04 and 10.10 I HAD the option to enable/disable guest access. I mean I HAD THAT OPTION. Now is gone. Do not know if it is a bug or a new default option. –  Luis Alvarado May 23 '11 at 1:41
up vote 1 down vote accepted

Found the solution after testing for a while. The most simple one is this:

sudo nano /etc/samba/smb.conf

In the [global] section after the [global] tag insert

usershare allow guests = yes

Should read like this:

[global]
usershare allow guests = yes

Save it and just restart Samba service: sudo service smbd restart .

Now reopen Nautilus. The option for guest should be enabled again when you try to share a folder as you can see in the image.

enter image description here

Already tested with Ubuntu 10.10, Windows XP and Windows 7. The thing is you need to remember to have Samba and the clients that will connect in the same workgroup which the variable can be found in the [global] part.

Hope this helps anyone else. For me i REALLY need this option since i share Movies, TV Series and Music over the network for several friends (And my girlfriend which is the 99.99% reason i needed this fast ;) )

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.