Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've set up my System to log me in automatically but for some reason I need to "unlock my keyring" x times, where x is a number much larger than one. I've read a few similar threads here and elsewhere but I've yet to find a solution to the problem.

How do I stop this from happening?

Seahorse screenshotSeahorse screenshot

Note : The original title described the behaviour as "molestation" which I think is apt.

share|improve this question
add comment

1 Answer

Right-click on your default keyring and change its password to nothing.

share|improve this answer
    
Isn't that "unsafe"? –  miloshadzic May 22 '11 at 20:15
    
yes - but you've already accepted the risk by using automatic login. If you use standard login, the keyring wouldnt be an issue. –  fossfreedom May 22 '11 at 20:27
    
So I need to either have zero protection for my passwords and other stuff or disable autologin? I thought the keyring was supposed to work like keepassx. Ie. you have one password that unlocks all the others. Just one pass after i get autologgedin. That would be great. –  miloshadzic May 22 '11 at 21:25
2  
It sounds like a bug to me. My answer is just a workaround. You're right, it shouldn't be doing this in the first place. –  Flimm May 24 '11 at 16:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.