Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

From the heartbleed.com website, I see that OpenSSL 0.9.8 is NOT vulnerable, which is the version that is available on 10.04. That should mean that actually having stuck with 10.04 until now has avoided any problems with this issue for my production servers.

Is that correct or am I still missing something and there is action that should be taken on 10.04 servers?

share|improve this question
add comment

2 Answers 2

up vote 9 down vote accepted

The version in 10.04 is too old to have the vulnerability, no action is needed over the heart bleed bug.

share|improve this answer
1  
OpenSSL 1.0.1 through 1.0.1f (inclusive) are vulnerable –  snez Apr 9 at 7:57
    
If you don't exactly know your Ubuntu version and the obvious command uname -a is not helpful, try lsb_release -d -s. –  Thomas W. Apr 9 at 20:07
    
+1 If you have 0.9.8 you are fine ; 10.04 is OK unless you've done something interesting. Use openssl version to check. –  belacqua May 12 at 19:20
add comment

you can check if your server is affected:

http://filippo.io/Heartbleed/#«yourserver.tld»

share|improve this answer
1  
This assumes that the server is currently publicly accessible.... –  belacqua May 12 at 19:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.