Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

From the website, I see that OpenSSL 0.9.8 is NOT vulnerable, which is the version that is available on 10.04. That should mean that actually having stuck with 10.04 until now has avoided any problems with this issue for my production servers.

Is that correct or am I still missing something and there is action that should be taken on 10.04 servers?

share|improve this question
up vote 11 down vote accepted

The version in 10.04 is too old to have the vulnerability, no action is needed over the heart bleed bug.

share|improve this answer
OpenSSL 1.0.1 through 1.0.1f (inclusive) are vulnerable – snez Apr 9 '14 at 7:57
If you don't exactly know your Ubuntu version and the obvious command uname -a is not helpful, try lsb_release -d -s. – Thomas Weller Apr 9 '14 at 20:07
+1 If you have 0.9.8 you are fine ; 10.04 is OK unless you've done something interesting. Use openssl version to check. – belacqua May 12 '14 at 19:20

you can check if your server is affected:«yourserver.tld»

share|improve this answer
This assumes that the server is currently publicly accessible.... – belacqua May 12 '14 at 19:18

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.