Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hey guys, Ive had some problems with my linux system, slowly been figuring things out. But im quite stumped on this problem, ill copy a section of code for you...

Errors were encountered while processing:
 rubygems1.8
 rubygems
E: Sub-process /usr/bin/dpkg returned an error code (1)
Everything else seemed to install fine, except for this piece of code which came before the one i just posted..
Setting up libruby1.8 (1.8.7.299-2) ...
Setting up ruby1.8 (1.8.7.299-2) ...
Setting up ri1.8 (1.8.7.299-2) ...
Setting up rubygems1.8 (1.3.7-2) ...
update-alternatives: error: alternative gem can't be master: it is a slave of ruby
dpkg: error processing rubygems1.8 (--configure):
 subprocess installed post-installation script returned error exit status 2
Setting up libc-dev-bin (2.12.1-0ubuntu10.2) ...
Setting up linux-libc-dev (2.6.35-1028.50) ...
Setting up libc6-dev (2.12.1-0ubuntu10.2) ...
Setting up ruby1.8-dev (1.8.7.299-2) ...
dpkg: dependency problems prevent configuration of rubygems:
 rubygems depends on rubygems1.8 (= 1.3.7-2); however:
  Package rubygems1.8 is not configured yet.
dpkg: error processing rubygems (--configure):
 dependency problems - leaving unconfigured
Setting up libdebconf-kde0 (0.1~svn1167939-0ubuntu3) ...
No apport report written because the error message indicates its a followup error from a previous failure.

Any ideas anyone?

share|improve this question

closed as too localized by belacqua, jrg, Jorge Castro, Marco Ceppi Oct 28 '11 at 15:39

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
have you tried sudo apt-get remove rubygems1.8 and then tried reinstalling it? –  jozzas May 23 '11 at 4:17
    
I would consider closing this as "too localized" due to disinterest and lack of general applicability. OP asked the question on May 22, hasn't been seen on site since May 23, hasn't responded to the comment on the question. –  belacqua Oct 28 '11 at 6:41
    
@belacqua It is abandoned. –  jrg Oct 28 '11 at 12:37
add comment

Browse other questions tagged or ask your own question.