Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

dpkg: error processing python-pkg-resources (--configure): subprocess installed post-installation script returned error exit status 137 dpkg: dependency problems prevent configuration of python-setuptools: python-setuptools depends on python-pkg-resources (= 0.6.28-1ubuntu2); however: Package python-pkg-resources is not configured yet.

dpkg: error processing python-setuptools (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of python-pip: python-pip depends on python-pkg-resources; however: Package python-pkg-resources is not configured yet. python-pip depends on python-setuptools (>= 0.6c1); however: Package python-setuptools is not configured yet.

dpkg: error processing python-pip (--configure): dependency problems - leaving unconfigured Errors were encountered while processing: python-pkg-resources python-setuptools python-pip

and

speedtest-cli Traceback (most recent call last): File "/usr/local/bin/speedtest-cli", line 5, in from pkg_resources import load_entry_point File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 17, in from urlparse import urlparse, urlunparse File "/usr/lib/python2.7/urlparse.py", line 116, in from collections import namedtuple ValueError: bad marshal data (string ref out of range)

Are the error messages that i get when i try to either upgrade ubuntu or run speedtest-cli. I personally have no idea what im doing so help is very much appreciated.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.