Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My ThinkPad X60 doesn't have a floppy drive. What is this "floppy0" icon for?

alt text

ak@myo5a:~$ ls -l /media/
total 8
lrwxrwxrwx 1 root root    7 2010-04-29 13:05 floppy -> floppy0
drwxr-xr-x 2 root root 4096 2010-04-29 13:05 floppy0
drwxr-xr-x 2 root root 4096 2010-05-12 10:33 iso
ak@myo5a:~$ ls /dev/scd*
ls: cannot access /dev/scd*: No such file or directory
ak@myo5a:~$ egrep -Rs "floppy|scd" /var/log
ak@myo5a:~$ 

I am not looking for a way to just make this icon go away. I want to understand why it is here.

share|improve this question

closed as too localized by ændrük, Marco Ceppi Jun 2 '11 at 15:50

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Please post the contents of your /etc/fstab file. –  psusi Apr 9 '11 at 18:29
    
I can no longer reproduce this after performing a fresh installation of 11.04. –  ændrük Jun 2 '11 at 15:04

3 Answers 3

You could try deleting 'floppy0' in /media.

Or perhaps blacklisting the floppy driver by editing

/etc/modprobe.d/blacklist.conf

and adding

blacklist floppy.

share|improve this answer
1  
Any idea what created /media/floppy0 in the first place? –  ændrük Sep 20 '10 at 18:44
    
There have been similar situations in the past; it might be a Thinkpad issue. Example: bugs.launchpad.net/ubuntu/+source/debian-installer-utils/+bug/… –  Ben Sep 20 '10 at 19:01

I was confused about this for a while on a computer I built without a floppy drive. I disabled the interface in the BIOS, even, yet it still was being seen by the OS. Turns out there was still an entry for the floppy drive in /etc/fstab that was causing it to be shown, even though there was nothing for it to load.

If removing the line there doesn't do the trick, try adding blacklist floppy to /etc/modprobe.d/blacklist.conf to prevent the kernel from loading the floppy driver at all.

share|improve this answer

The floppy disk drive is a legacy drive and is incorporated in most operating systems so that it is available if required.

Since the distributions of Linux cannot match every hardware configuration they do their best guess at matching the most configurations and hence they have not completely removed it in you particular case.

If you added an external floppy drive you would at least have the device available (although I think it is still blocked somewhere)

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.