Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I´ve installed a test environment for MAAS and JUJU. MAAS manages both DHCP and DNS. Following setup:

  • maas01 - static IP
  • juju01 - dhcp and dns from maas01
  • node01 - dhcp and dns from maas01 and pxe boot

The node01 starts just fine and the juju is able to resolve it correctly. All the maschines have access to the internet through the gateway.

When I´m trying to bootstrap the juju with the maas, the juju connects to the node01 and does some apt-get stuff. It throws an error on downloading the current agent.

I´ve tried to do some apt-get on the node01. Works just fine. But everything else is not possible (pinging google,...)

I do not understand this behaviour, because of the juju01 getting the same DHCP and DNS data from the maas01.

Any Idea how I can get my nodes to have access to the Internet?

Thank you!

Hauke

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

Solved it!

It was the fault of the VMware vCloud, the environment was set up. The vCloud only NATs Machines with an IP Address. Because of the lack of VMware Tools on the deployed MAAS Nodes VMware couldn't determent the IP Address and therefor NATing wasn't enabled for those machines. apt-get worked because of the squid proxy installed on the MAAS.

Workaround: I created a new virtual router and set it as the gateway for the MAAS nodes. BOOM :) Full internet access and no problems with bootstrapping.

Greetings, Hauke

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.