Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell Vostro 3300, which has a Broadcom BCM4313 wireless. The point is that I cannot make it work in N mode. NetwotkManager applet says I'm on 54 Mbit/s. Of course, my wireless router is N capable. I've double checked. Anyone knows what to do?

Here is the output for lspci -v:

12:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
    Subsystem: Dell Device 0010
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at fbb00000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: wl
    Kernel modules: wl, brcm80211

Thanks a lot.

share|improve this question

1 Answer 1

Actually, I didn't know I needed to set WPA2 with AES encryption. Anyway, this wireless card is not the best one around - is only capable of 72 Mb/s, which is the speed I have now after setting this encryption type...

share|improve this answer
    
Hmm. The laptop I'm on at the moment has a BCM4313 and it works beautifully with 2.6.39. As a side note, you don't want to use the wl (STA) driver. Blacklist it. brcm80211 also now known as brcmsmac in newer kernels, is a much better, more stable driver. I didn't know about the speed limit. Why make a N device and then hobble it so it can only go at a quarter of its possible speed?! –  Oli Jul 21 '11 at 23:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.