Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have connected to remote Linux desktop (Ubuntu 13.10) using ssh command and try to run following command on remote desktop. On my host machine I am using Ubuntu 12.04.

On remote desktop:

I have copy of FriendlyARM board's toolchain at '/home/linuxUser/FriendlyArm/opt/FriendlyARM/toolschain/4.5.1/' location.

I open a terminal set PATH environment variable by,

$ export PATH=/home/linuxUser/FriendlyArm/opt/FriendlyARM/toolschain/4.5.1/bin:$PATH

now try to run my hello.c program by

$ arm-linux-gcc hello.c

I got error:

-bash: /home/linuxUser/FriendlyArm/opt/FriendlyARM/toolschain/4.5.1/bin/arm-linux-gcc: No such file or directory

I run following command for some more information

$ echo $PATH

/home/linuxUser/FriendlyArm/opt/FriendlyARM/toolschain/4.5.1/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games

$ ls -l ~/FriendlyArm/opt/FriendlyARM/toolschain/4.5.1/bin/arm-linux-gcc

lrwxrwxrwx 1 linuxUser linuxUser 26 Sep 28  2010 /home/linuxUser/FriendlyArm/opt/FriendlyARM/toolschain/4.5.1/bin/arm-linux-gcc -> arm-none-linux-gnueabi-gcc

ls -l ~/FriendlyArm/opt/FriendlyARM/toolschain/4.5.1/bin/arm-none-linux-gnueabi-gcc

-r-xr-xr-x 2 linuxUser linuxUser 249588 Sep 24  2010 /home/linuxUser/FriendlyArm/opt/FriendlyARM/toolschain/4.5.1/bin/arm-none-linux-gnueabi-gcc
share|improve this question
    
Did you try /home/linuxUser/FriendlyArm/opt/FriendlyARM/toolschain/4.5.1/bin/arm-linux-gcc hello.c –  Sylvain Pineau Apr 7 at 8:41
    
I tried that also but got same error. –  beparas Apr 7 at 9:03
    
Did you restart the system or logout and back in? –  ChrisR. Apr 7 at 10:52
1  
The program can't find a library it depends on. Run ldd ~/FriendlyArm/opt/FriendlyARM/toolschain/4.5.1/bin/arm-none-linux-gnueabi-gcc to see what libraries it wants and can't find. –  psusi Apr 7 at 14:40

1 Answer 1

up vote 2 down vote accepted

It's not related to a $PATH error, on 13.10 you need to install the 13.04 ia32-libs package.

You can download the ia32-libs package from the raring repository.

Download it from a mirror and install it manually, then you should run the arm-none-linux-gnueabi-gcc executable.

sudo dpkg -i ./ia32-libs_20090808ubuntu36_amd64.deb
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.