Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently created a vps for web hosting purposes. Everything was going fine until I decided that it's time to add another account and disable root authentication. I added a new user to the sudoers group, added the public key to the /home/user/.ssh/authorized_keys file, checked all the file permissions, and the outcome is that I can only login via password authentication. When using the ssh key, this is the super super verbose output:

chev@linuxbox:~/.ssh$ ssh -vvv user@xxx.xxx.218.10 -p 25000   
OpenSSH_5.9p1 Debian-5ubuntu1.2, OpenSSL 1.0.1 14 Mar 2012 debug1:   
Reading configuration data /etc/ssh/ssh_config debug1:   
/etc/ssh/ssh_config line 19: Applying options for * debug2:   
ssh_connect: needpriv 0 debug1: Connecting to xxx.xxx.218.10   
[xxx.xxx.218.10] port 25000. debug1: Connection established. debug3:  
Incorrect RSA1 identifier debug3: Could not load   
"/home/chev/.ssh/id_rsa" as a RSA1 public key debug1: identity file   
/home/chev/.ssh/id_rsa type 1 debug1: Checking blacklist file   
/usr/share/ssh/blacklist.RSA-2048 debug1: Checking blacklist file   
/etc/ssh/blacklist.RSA-2048 debug1: identity file   
/home/chev/.ssh/id_rsa-cert type -1 debug1: identity file   
/home/chev/.ssh/id_dsa type -1 debug1: identity file   
/home/chev/.ssh/id_dsa-cert type -1 debug1: identity file   
/home/chev/.ssh/id_ecdsa type -1 debug1: identity file   
/home/chev/.ssh/id_ecdsa-cert type -1 debug1: Remote protocol version
   2.0, remote software version OpenSSH_5.9p1 Debian-5ubuntu1.2 debug1: match: OpenSSH_5.9p1 Debian-5ubuntu1.2 pat OpenSSH* debug1:
Enabling    compatibility mode for protocol 2.0 debug1: Local version
string    SSH-2.0-OpenSSH_5.9p1 Debian-5ubuntu1.2 debug2: fd 3 setting
O_NONBLOCK debug3: put_host_port: [xxx.xxx.218.10]:25000 debug3:   
load_hostkeys: loading entries for host "[xxx.xxx.218.10]:25000" from 
file "/home/chev/.ssh/known_hosts" debug3: load_hostkeys: found key   
type ECDSA in file /home/chev/.ssh/known_hosts:19 debug3:   
load_hostkeys: loaded 1 keys debug3: order_hostkeyalgs: prefer   
hostkeyalgs:   
ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521
debug1: SSH2_MSG_KEXINIT sent debug1: SSH2_MSG_KEXINIT received   
debug2: kex_parse_kexinit:   
ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit:   
ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-rsa-cert-v01@openssh.com,ssh-dss-cert-v01@openssh.com,ssh-rsa-cert-v00@openssh.com,ssh-dss-cert-v00@openssh.com,ssh-rsa,ssh-dss    debug2: kex_parse_kexinit:   
aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit:   
aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit:   
hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96    debug2: kex_parse_kexinit:   
hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96    debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib debug2:   
kex_parse_kexinit: none,zlib@openssh.com,zlib debug2:   
kex_parse_kexinit:  debug2: kex_parse_kexinit:  debug2:   
kex_parse_kexinit: first_kex_follows 0  debug2: kex_parse_kexinit:   
reserved 0  debug2: kex_parse_kexinit:   
ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss,ecdsa-sha2-nistp256   
debug2: kex_parse_kexinit:   
aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit:   
aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit:   
hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96    debug2: kex_parse_kexinit:   
hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96    debug2: kex_parse_kexinit: none,zlib@openssh.com debug2:   
kex_parse_kexinit: none,zlib@openssh.com debug2: kex_parse_kexinit:   
debug2: kex_parse_kexinit:  debug2: kex_parse_kexinit:   
first_kex_follows 0  debug2: kex_parse_kexinit: reserved 0  debug2:   
mac_setup: found hmac-md5 debug1: kex: server->client aes128-ctr   
hmac-md5 none debug2: mac_setup: found hmac-md5 debug1: kex:   
client->server aes128-ctr hmac-md5 none debug1: sending   
SSH2_MSG_KEX_ECDH_INIT debug1: expecting SSH2_MSG_KEX_ECDH_REPLY   
debug1: Server host key: ECDSA   
xx:xx:xx:xx:65:ef:d9:33:0c:55:58:e3:9f:32:36:07 debug3:   
put_host_port: [xxx.xxx.218.10]:25000 debug3: put_host_port:   
[xxx.xxx.218.10]:25000 debug3: load_hostkeys: loading entries for   
host "[xxx.xxx.218.10]:25000" from file "/home/chev/.ssh/known_hosts" 
debug3: load_hostkeys: found key type ECDSA in file   
/home/chev/.ssh/known_hosts:19 debug3: load_hostkeys: loaded 1 keys   
debug3: load_hostkeys: loading entries for host   
"[xxx.xxx.218.10]:25000" from file "/home/chev/.ssh/known_hosts"   
debug3: load_hostkeys: found key type ECDSA in file   
/home/chev/.ssh/known_hosts:19 debug3: load_hostkeys: loaded 1 keys   
debug1: Host '[xxx.xxx.218.10]:25000' is known and matches the ECDSA  
host key. debug1: Found key in /home/chev/.ssh/known_hosts:19 debug1: 
ssh_ecdsa_verify: signature correct debug2: kex_derive_keys debug2:   
set_newkeys: mode 1 debug1: SSH2_MSG_NEWKEYS sent debug1: expecting   
SSH2_MSG_NEWKEYS debug2: set_newkeys: mode 0 debug1: SSH2_MSG_NEWKEYS 
received debug1: Roaming not allowed by server debug1:   
SSH2_MSG_SERVICE_REQUEST sent debug2: service_accept: ssh-userauth   
debug1: SSH2_MSG_SERVICE_ACCEPT received debug2: key:   
/home/chev/.ssh/id_rsa (0xb8a7f868) debug2: key: donotaccept@gmx.com  
(0xb8a87c40) debug2: key: /home/chev/.ssh/id_dsa ((nil)) debug2: key: 
/home/chev/.ssh/id_ecdsa ((nil)) debug1: Authentications that can   
continue: publickey debug3: start over, passed a different list   
publickey debug3: preferred   
gssapi-keyex,gssapi-with-mic,publickey,keyboard-interactive,password  
debug3: authmethod_lookup publickey debug3: remaining preferred:   
keyboard-interactive,password debug3: authmethod_is_enabled publickey 
debug1: Next authentication method: publickey debug1: Offering RSA   
public key: /home/chev/.ssh/id_rsa debug3: send_pubkey_test debug2:   
we sent a publickey packet, wait for reply debug1: Authentications   
that can continue: publickey debug1: Offering RSA public key:   
donotaccept@gmx.com debug3: send_pubkey_test debug2: we sent a   
publickey packet, wait for reply debug1: Authentications that can   
continue: publickey debug1: Trying private key:   
/home/chev/.ssh/id_dsa debug3: no such identity:   
/home/chev/.ssh/id_dsa debug1: Trying private key:   
/home/chev/.ssh/id_ecdsa debug3: no such identity:   
/home/chev/.ssh/id_ecdsa debug2: we did not send a packet, disable   
method debug1: No more authentication methods to try. Permission   
denied (publickey).

This happens with both the root and non-root account. After logging in with password, I also noticed that instead of user@host:$ prompt i just get a "$" prompt. I did create a home and .ssh folder, so not sure about that one, but more annoyed with not being able to login. Also, this happens on port 22 as well. I've spent the last 12 hours trying to get this to work. The only thing I can do is re-flash my vps and stick to root login with ssh key, which is not what I want. Every time I try to change that setup, I run into a multitude of problems. Can someone please offer some advice?

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

In case anyone stumbles across this post with a simular issue, this was resolved when I regenerated and recopied the ssh keys over to the vps. Now everything works great. So, if you are simular error messages, try rotating your keys. It worked for me!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.