Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have ffmpeg install from apt (version 4:0.5.1-1ubuntu1). I have a video that is up-side-down, so I want to flip it vertically. The ffmpeg documentation says to use the -vf option (which I see was recently renamed from -vfilters). However that just doesn't work for me. I get an error like: ffmpeg: unrecognized option '-vf'.

I know there are all kinds of legal reasons why ffmpeg is not the full options, but surely flipping a video should be OK? There are many guides for ubuntu and ffmpeg which advise to recompile it yourself. e.g. the number 2 hit for "ubuntu ffmpeg" is a guide on ubuntu forums on recompiling ffmpeg yourself.

I don't want to recompile it myself. I am a fan of package managers and "doing things the right way". There should be a way to get this functionality in the packaged version, otherwise there is a bug in the packaged version.

How can I get the -vf/-vfilter option in ffmpeg? (If I can't get it, why not?)

share|improve this question
add comment

3 Answers

up vote 5 down vote accepted

You are right, the ffmpeg packages in Ubuntu 10.04 and 10.10 do not support video filters. If you use Ubuntu 10.10, you can add unofficial packages from the Debian Multimedia Project and install their ffmpeg version (you should not do this if you use Ubuntu 10.04, there are too many conflicts with older packages. Also do not combine those packages with ubuntu-restriced-extras). Then the following works

ffmpeg -i in.avi -vf vflip out.avi

An easier option ̣- if all you want to do is flip videos - is to use the mencoder package instead of ffmpeg. After installing the package, the following works (copying the audio, encoding the video with libavcodecs):

mencoder -vf flip -o out.avi -oac copy -ovc lavc in.avi
share|improve this answer
    
Do you know why the ffmpeg in ubuntu don't do this? Is the version of ffmpeg too old? Or was this delibrately switched off? –  Rory Sep 21 '10 at 22:30
1  
The ffmpeg version (at least in Maverick) is quite recent, it has something to do with configure options. It is not Ubuntu specific, the limitation is inherited from Debian I think: bugs.debian.org/cgi-bin/bugreport.cgi?bug=594108 –  Marcel Stimberg Sep 22 '10 at 8:35
add comment

you could try avconv

http://superuser.com/questions/507386/libav-vs-ffmpeg-better-to-use-libav-avconv-today

looks to me like libav is thought to become a successor of ffmpeg

share|improve this answer
    
libav is a fork of FFmpeg, not a successor. See Who can tell me the difference and relation between ffmpeg, libav, and avconv? –  LordNeckbeard Jun 28 '13 at 0:11
add comment

If you don't want to compile it yourself, you should just grab a static build from the ffmpeg Downloads page (scroll down to 'FFmpeg Linux Builds').

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.