Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've some problem connecting to certain websites, using Ubuntu 12.04 in Dual Boot Windows 7.

Websites like https://github.com/, https://developer.paypal.com/ and https://www.facebook.com/ keeps on loading for long time.

Its so weird, it opens sometimes, then it doesn't sometimes.

I don't know how to debug this issue. So far what i tried is using PING command.

$ ping github.com

PING github.com (192.30.252.129) 56(84) bytes of data.

--- github.com ping statistics ---
92 packets transmitted, 0 received, 100% packet loss, time 90999ms

On doing that on google, it works fine.

$ ping google.com
PING google.com (74.125.236.73) 56(84) bytes of data.
64 bytes from maa03s05-in-f9.1e100.net (74.125.236.73): icmp_req=1 ttl=56 time=26.1   ms
64 bytes from maa03s05-in-f9.1e100.net (74.125.236.73): icmp_req=2 ttl=56 time=27.7 ms
64 bytes from maa03s05-in-f9.1e100.net (74.125.236.73): icmp_req=3 ttl=56 time=26.0 ms
64 bytes from maa03s05-in-f9.1e100.net (74.125.236.73): icmp_req=4 ttl=56 time=26.2 ms

--- google.com ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4005ms
rtt min/avg/max/mdev = 25.070/26.259/27.798/0.882 ms

Really need some help!! I tried googling, not even sure how to search it!!

(using wireless)

share|improve this question
    
Not all web servers respond to ping requests all the time. To find out if this is a browser issue or a network issue, try retrieving the sites using the wget command. If the page loads fast in wget, it is probably a browser issue. –  Jos Apr 6 at 14:59
    
@Jos: Thx! I'll check it right way! –  sk8terboi87 ツ Apr 6 at 15:35
1  
Even your country matters.some countries like china do not allow encrypted connections.You will need to check that in your case. –  Registered User Apr 6 at 15:55
    
github.com successfully responds to pings for me. Also, @AdityaPatil whether or not a server responds to pings is unrelated to whether the connection is encrypted - a ping is a different type of communication that is never encrypted. –  neon_overload Apr 9 at 6:18
1  
Possible duplicate of Problem resolving many of the Web Pages –  Aditya Apr 9 at 13:22

3 Answers 3

Ruling out it being an HTTPS specific problem

Websites like https://github.com/, https://developer.paypal.com/ and https://www.facebook.com/ keeps on loading for long time.

It just so happens that these three sites all communicate over HTTPS rather than HTTP.

Some networks may block HTTPS connections, or connections on particular ports (HTTPS uses port 443 instead of port 80) as a matter of policy. However, I'm willing to guess that this isn't actually your problem. To rule out this possibility, you'll need to find an HTTPS site that works. Does, for example, https://askubuntu.com/ work? It should. If not, your problem may be related to HTTPS sites.

Another type of filtering by your ISP?

However, there is still another issue: your ping result suggests the problem is not related to your use of HTTPS (as ping does not use HTTPS).

--- github.com ping statistics ---
92 packets transmitted, 0 received, 100% packet loss, time 90999ms

This suggests that the problem isn't HTTPS. It could still be that your internet connection is filtered in some way. For example, ping could have been filtered in addition to those HTTPS connections.

Does your internet access require a proxy?

On the other computers that work, check if they access the web via some proxy server. This may need to be configured in your operating system. On Windows based browsers these settings can be accessed from within the browser settings of any browser - look for proxy settings. It's possible that you need to set up equivalent proxy settings in Ubuntu.

Could it be a routing issue with your ISP

Occasionally an ISP may have a routing issue, whereby a connection upstream to them is temporary down, blocking access to some sites. This will often be a temporary issue and resolved relatively quickly.

It is rare, however, for such issues to block only some sites but leave access to all other sites. It could however mean that you can access local sites - sites hosted geographically near you - and are temporarily unable to access more distant sites such as overseas hosted sites.

share|improve this answer

I am not sure this will work or not . But I think you can check the website with

http://www.isitdownrightnow.com/

If the website is working then install add-on to your browser form http://www.webproxy.net/

Try to visit the website. Actually it worked for me several times. Hope it works for you too.

share|improve this answer

At first I was going to say it may be a DNS problem, but after looking at your screen-shot of the ping to github.com, I don't think it is. The IP is correct, and it should reply back. I tested on my machine (12.04) here in the central U.S. and I get a average time of 68 ms and no packet loss.

You should contact your ISP and have them test your connection because something isn't working correctly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.