Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having problems when I want to use a folder name containing a blank (Hentede filer in my case). It is in the line: Exec= Hentede filer of the .desktop file but that doesn't work.

[Downloads Shortcut Group]
Name=Hentede filer
Exec=nautilus Hentede filer
TargetEnvironment=Unity
share|improve this question

2 Answers 2

Change it to nautilus "Hentede filer"

For future reference: you can test these by issueing the command in a terminal like so:

im1.

It will open it if it the command is correct or give an error message if it is not. Since I do not have a "Hentede filer" I get this message:

im2

But as you can see it errors out on not finding it but it does show it tries to open it the way you want it to.

share|improve this answer
    
Thanks a lot - it works. –  Knud Petersen May 22 '11 at 21:57

Try changing to:

[Downloads Shortcut Group]
Name=Hentede filer
Exec=nautilus Hentede\ filer
TargetEnvironment=Unity

In fact, in linux blanks are identified by the "\" key code (backslash+blank).

share|improve this answer
    
Actually, the "\" (backslash) is used to prefix characters that cannot be entered as-is. So, when you enter "Hentede\ filer" the space will be made part of the parameter, not a parameter separator. –  jfmessier May 22 '11 at 22:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.