Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have setup Ubuntu 11.04 to use Jack and PulseAudio just to get sound working. It was a little tough, but I got it to work.

Now as I use my computer - like Banshee, Youtube, or VLC - the FA-66 will just drop out and I am forced to stop/start Jack using qJackCtl.

This is pretty annoying because I have to exit out of most programs after I restart Jack (like Firefox).

Eventually I am forced to reboot because the starting/stopping of Jack has to happen ever more frequently.

How can I fix this? I am not a linux expert, so if you need me to give you information, just tell me what commands to run and I can past the output here. I'd really like to get this fixed.

JackEngine::XRun: client PulseAudio JACK Sink finished after current callback
JackEngine::XRun: client = PulseAudio JACK Source was not run: state = 1
JackEngine::XRun: client = PulseAudio JACK Sink was not run: state = 1
JackAudioDriver::ProcessGraphAsync: Process error
JackPosixMutex::Unlock res = 1
JackPosixMutex::Unlock res = 1
JackPosixMutex::Unlock res = 1
04:46:33.692 XRUN callback (1).
JackPosixMutex::Unlock res = 1
JackEngine::XRun: client = PulseAudio JACK Source was not run: state = 2
JackEngine::XRun: client PulseAudio JACK Sink finished after current callback
JackAudioDriver::ProcessGraphAsync: Process error
JackPosixMutex::Unlock res = 1
JackPosixMutex::Unlock res = 1
JackPosixMutex::Unlock res = 1
04:46:34.723 XRUN callback (6 skipped).

Thank you.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

It's possible like the jack/pulse combination is aborting due to XRUNs, which mean that the audio data couldn't be completed within the time required.

You can prevent XRUNs by setting the jack period size. In the Jack Settings (in qjackctl, click the 'Setup' button, and look in the 'Settings' tab), there's a parameter labelled 'Frames/Period'. Try increasing this value.

Note that increasing the period size will also increase the audio latency. But, unless you're doing realtime audio processing, this probably won't affect you.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.