Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

This question already has an answer here:

GPG error: natty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 16126D3A3E5C1192

I think I selected to install things from when I used the expert mode installer, but I got the above error when doing apt-get update. How do I fix this?

share|improve this question

marked as duplicate by Seth, Eric Carvalho, Luis Alvarado Aug 8 '13 at 15:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Official repositories like "Ubuntu Extras" are actually linked and have packages. To install this pubkey, merely run apt-get install ubuntu-extras-keyring (You can find others with a command like apt-cache search repo |grep .-keyring which also works for Debian) – Adam Katz Oct 7 at 23:26

1 Answer 1

up vote 10 down vote accepted
gpg --keyserver --recv 3E5C1192
gpg --export --armor 3E5C1192 | sudo apt-key add -
sudo apt-get update

This could be a solution. From

You can also get all launchpad keys automatically using the below method

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install launchpad-getkeys
sudo launchpad-getkeys


Ubuntu Extras keyring error

share|improve this answer
Had the same problem as above on my 11.10 laptop. What's more, I had an annoying red triangle right next to my battery indicator. Tried a few other suggestions around the internet, but this worked great. – thebretness Dec 13 '11 at 4:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.