Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just installed Ubuntu 12.04 on my Acer Aspire 2930z, along side my Windows 7 (Dual Boot).

Problem is - I can't get a wifi connection - the wifi button is off and doesn't respond. Connection is good with ethernet cable and with the wifi on Windows.

I guess some driver is needed, but I have no idea though. I've tried sudo apt-get update, as well as apt-get upgrade and bcmwl-kernel-source, all kinds of stuff I found on the internet as a possible solution.

  • If anyone knows the "correct answer" to my problem, it would be really helpful. -- Thanks!
share|improve this question
    
i have a same problem but on Wxp... The drivers for wireless in ACER WEB, simply not working. There is a old or defective drivers. In my case i resolved this problem searching drivers on google. I reinstall new drivers and problem go out.... working wifi and button without problem. I am not expert in linux, but i hope this help you to solve the problem. –  Lluis Mas Apr 14 at 18:19
    
Do you know what Wi-Fi card the computer has? In the terminal, type the following command: lspci It will probably be under the "Network Controller" entry. It looks like Acer uses rebranded Atheros or Broadcom cards. Is the wi-fi card even detected? –  EricPineapple Apr 14 at 21:12
    
I have the same problem on my Acer Aspire 3020; Wireless internet is activated by a button with LED on the front of the notebook, however, it only works with Windows XP, not with Ubuntu LTS 12.04. The problem is the software called "Launch Manager" that Acer supplies for its computers, but only for Microsoft Windows operating systems, not for Ubuntu, (look it up on acer.nl/ac/nl/NL/content/drivers for Dutch users but also on the Acer.com website for other nationalities). The problem would be solved if Acer, the hardware manufactures (in my case Dritek) or someone else would make "La –  Raggy Apr 16 at 8:50

protected by Community Apr 16 at 10:37

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.