Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do I mount Shares from an Iomega ix4-200d?

Plug-and-play from Windows with the included installation CD, but not a word about Linux.

It looks like there are several ways to do it; I have put my current solution below.

share|improve this question
add comment

2 Answers

Not knowing anything about such endeavors, this took me about 4 hours to figure out. It turns out the procedure is very simple.

  1. Log into your ix4 from the web browser (you should see the IP address on the drive screen).
  2. Click the "Network" icon then the "Protocol" icon.
  3. See the little penguin next to "NFS"? That's your Linux documentation (nice of them).
  4. Turn NFS on. Yes, it was off by default. Again, that was nice of them.
  5. sudo mount -t nfs 192.168.1.113:/nfs/SHARENAME /mnt/yourdir
  6. SHARENAME above is just the name of your Share on the ix4 without embellishment. Keep the /nfs. Obviously, change the IP address to whatever your's is.
  7. /mnt/yourdir is a directory you've created with mkdir. Actually, it can be anywhere. /mnt is the canonical place.
  8. If your Ubuntu installation was like mine, the above command will fail because you do not have a file called mount.nfs in your /sbin directory. Quite an oversight on your part. Install it with apt-get install nfs-common.

Once you get it working you can put a similar line in /etc/fstab, so your Shares are automatically mounted. Section 4.2 and 4.3 of the Sourceforge nfs resource explain how to do it.

Kudos to Eric Crossley's Blog which has the idea of mounting as NFS and the basic mount command. He has a few more useful ix4 setups there as well.

share|improve this answer
1  
I have had an ix2 200 for two years and that's the way I use to connect to it. You could also connect using samba or ftp, but I think nfs is the better. –  Nachito Oct 11 '11 at 16:12
add comment

I just intalled it; thanks for your help but I needed a few different settings.

sudo mount //192.168.1.89/public ~/Iomega -o uid=1000, gid=1000,rw,username='admin',password=#########

I just want to point out the diffrences (and might state the obvious but I am new to Linux):

  • addressing the network works only with //a.b.c.d. and very mean,
  • the (German) settings on the ix2 tells you to mount to //a.b.c.d/nfs/.... and this should be /public.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.