Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an HP laptop ENVY m6, with 8 Gb of RAM and a 750 Gb HDD. It came with windows 8 pre-installed and I installed Ubuntu 13.04. It worked fine but after upgrading Ubuntu to 13.10 my laptop fails to boot showing this error:

error:file /boot/grub/i386-pc/normal.mod  not found 
Entering rescue mode 
grub rescue>

I tried to fix this error with BootRepair without any luck. I got this BootInfo. Help me please fixing this problem, I have struggled consecutively for four days.

Note: in my BIOS settings I have disabled secure boot, but legacy support is enabled.

share|improve this question

marked as duplicate by Rod Smith, Avinash Raj, Radu Rădeanu, Eric Carvalho, mikewhatever Apr 6 '14 at 20:16

This question was marked as an exact duplicate of an existing question.

^^ This alone will solve your problem. – Avinash Raj Apr 5 '14 at 13:38