Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
How can I get Broadcom BCM4311 Wireless working?

I have an Ideapad U330 with a Broadcom Wlan card.

Originally I was on Maverick. And my card worked fine. I had to manually enable wireless every time I booted up but that wasn't a big hassle for me.

Then I switched to Natty. It recognized my Broadcoam, suggested the driver in Additional Hardware, and installed it. However, nothing worked in Natty. I would click "Enable Wireless" and nothing would work. Or it would give me a message saying that Wireless was Disabled due to the hardware switch being off---when it wasn't.

So then I completely erased everything, went back to Maverick, and my wireless is working now.

I'm curious though. Would upgrading directly from Maverick using Synaptic work?

Is this a big issue for Broadcom drivers going into Natty?

Any information or insight would be much appreciated. You guys and gals are always the best help on here.

share|improve this question

marked as duplicate by RolandiXor, Octavian Damiean, Jjed, Bruno Pereira, Jorge Castro Jan 28 '12 at 1:42

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Broadcom in Ubuntu always calls for trouble. The sytem offers you normally two drivers to install. I have Broadcom STA driver installed and it works fine and never made any trouble after upgrading. Which one do you have installed? Look under system, additional driver. – dago May 22 '11 at 20:57
You may be experiencing bug #732677. Can you please edit your question to include the output of sudo lshw -class network and lsmod | grep -E 'b43|ssb|wl'? – ændrük May 23 '11 at 16:22
Yes, Broadcom is not so friendly to Ubuntu. I had similar problems with BCM4313 under Natty. You could try solution offered here… (by neyz), probably it will help you to solve an issue. – Justas Sep 5 '11 at 6:36
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, then please flag explaining that (as well as editing your question with any details you have). – James Jan 27 '12 at 15:34

Just also posted this in another similar post

I would perhaps re install your drivers which should not take long Do this via a terminal and you should see if anything goes wrong

So in a terminal type the following

sudo apt-get remove b43-fwcutter firmware-b43-installer


sudo apt-get install b43-fwcutter firmware-b43-installer.

This should reinstall your wifi driver

Alternatively what I have done is install the other broadcom proprietry driver STA

This was just as easy again via the terminal

Clear out any older files

sudo apt-get remove bcmwl-kernel-source
sudo apt-get install bcmwl-kernel-source
share|improve this answer
How do you know he was using firmware-b43-installer to begin with? – ændrük May 23 '11 at 16:23
I dont/cant from here but at least if they do have it,it will clear it out so they can reinstall it properly again just in case that is the problem. Or they can try the other driver. Lets see if we get some info back from them about your question as well cause that will also shed some light – andybleaden May 23 '11 at 20:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.