Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Most probably after a forced reboot, whenever I load xfce4 on my Ubuntu 13.04 I get this environment that looks like a buffed-up xterm, where I have an invisible mouse cursor: when I move around I cannot see a cursor but when it happens to go hover over a press-able button, the button changes color. I tried quitting that and starting X by startx but the only thing I got was a black screen. I proceeded as following:

  • Tried uninstalling and reinstalling xfce4 by:
    • sudo apt-get remove --purge xfce4
    • sudo apt-get install xfce4
  • It did not work so I also tried:
    • sudo apt-get remove --purge libxfce4util-common
    • sudo apt-get install xfce4
  • It also did not work so after removing xfce4 I also tried removing and reinstalling xorg:
    • sudo apt-get remove --purge xserver-xorg
    • sudo apt-get install xserver-xorg
    • sudo dpkg-reconfigure xserver-xorg
  • Unfortunately this did not work either so I tried deleting also ~/.XAuthority* but this did not work either.
  • I also attempted to startx after reinstalling xorg and before installing xfce4 but I was again getting just a black screen which makes very worried.

Any ideas?

share|improve this question

1 Answer 1

I tried logging in as root, as opposed to the regular user I was logging in before, and everything was working fine. This seemed to indicate that it was more of a configuration issue than an xfce4 corruption.

Therefore I logged in again as the regular user that had the problem and deleted the configuration folder, after terminating xfce4 process:

mv ~/.cache/sessions ~/.cache/sessions.bak

Then I restarted xfce4 and everything was working great! Hope that proves helpful for some people.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.