Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got several Ubuntu machines on my network at home, but the DNS is provided by a windows server (2K). When I ssh to them from another , if I ssh to them as "machine" I can't connect, but if I connect as "machine.local" I can connect.

I think similarly, I can't connect from a windows client (like putty).

What's going on here? - it's clearly an Ubuntu thing.

share|improve this question
    
Actually, it looks like a DNS thing, not like an Ubuntu thing at all (especially since you “can't connect” from the Windows machine — and what is the error message anyway?). What is your DNS configuration (nameserver and search)? How does dig machine1 differ from dig machine1.local? –  Gilles Sep 20 '10 at 23:34
    
Would you happen to have Apple Bonjour or another Zeroconf implementation installed on the Windows 2000 Server? –  Thorbjørn Ravn Andersen Sep 21 '10 at 3:04

2 Answers 2

up vote 15 down vote accepted

By default, Ubuntu includes avahi. This is an implementation of zeroconf which allows computer hostnames to be resolved with the virtual ".local" name. Whenever your computer tries to connect to "hostname.local", avahi will perform local network broadcasts to see if there any computers with that hostname. Other computers running avahi (or something compatible) should answer.

If you look in /etc/nsswitch.conf, you will find the following line:

hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4

The mdns4_minimal is the configuration setting that makes this redirection work.

Your question actually suggests that avahi is running successfully as you say that you can connect to your Ubuntu computers using "hostname.local". However, you do not make it clear ("When I ssh to them from another, ...") if you are trying to connect from another Ubuntu computer, or from another Windows computer. Without installing other software such as Bonjour, Windows computers cannot resolve zeroconf-style "hostname.local" names.

share|improve this answer
    
Avahi Link for the interested. In short, its complicated. –  meawoppl Sep 9 '13 at 23:12

To fix your issue, you just need Avahi. This announces your Ubuntu machine names to the Windows lot.

sudo apt-get install avahi-daemon

machinename.local works thanks to another implementation of zeroconf (of which Avahi is also) called Bonjour, created (IIRC) by Apple. It's installed by default. I don't know why Avahi isn't also but given the confusion it causes people, it probably aught to be.

There's more on this on Wikipedia: http://en.wikipedia.org/wiki/.local

share|improve this answer
    
Avahi uses .lan I think –  Broam Sep 20 '10 at 17:15
2  
No, avahi uses .local, this is required by the mDNS spec. –  Kees Cook Oct 27 '10 at 6:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.