Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently switched from Ubuntu to Xubuntu. All is well except for a single fn key that doesnt' seem to work.

I have an Asus n56vz which has a huge touchpad. So I'd like to disable it when I have a mouse plugged in, because I keep touching it with my palm and it annoys me to death.

In Ubuntu these shortcuts just worked out of the box, however for Xubuntu this doesn't seem to be the case for the touchpad.

Is there a configuration to enable this shortcut (fn+f9 in my case) or either a setting that automatically disables my touchpad when a mouse is plugged in?

Thanks in advance.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Xubuntu is great I highly recommend xfce over Unity. But Xubuntu uses xfce4 which has its own key shortcut mappings which are not controlled by "Ubuntu" as it is on the Unity desktop. There may be one in Settings > keyboard > shortcuts or Settings > Windows > Keyboard Shortcuts for disabling touchpad (I cannot verify this right now), or you can map whichever a custom key combo to the command:

synclient TouchpadOff=1

if this does not work you can also enable an input daemon to autostart which will enable/disable touchpad automatically during keyboard activity:

http://goo.gl/e4DMem

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.