Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04 on a MacBook air - everything works fine, apart from the fact that the screen dims after 60 seconds of activity. Is there any way to stop this?

My computer is on mains power. If I stop using the machine, after 30 seconds the keyboard backlight turns off (that's fine). After a minute, the screen dims by about 50% - this is annoying, especially when watching a video or reading a long page of text.

My "brightness and lock" settings seem fine:

enter image description here

I've tried

gsettings set org.gnome.settings-daemon.plugins.power idle-dim-time 600

But that doesn't make a difference - it still dims after 60 seconds, no matter what value I set it to.

I've also used gconf-editor but I don't appear to have /apps/gnome-power-manager/backlight

I'm not using Unity - just the standard Gnome desktop.

Is there any way to change this behaviour? I never want my screen to dim. I'm quite happy controlling it manually with the F1 and F2 keys.

EDIT

No - Caffeine doesn't work. The screen still dims.

No - changing the DPMS doesn't work.

No - Editing stuff in dconf doesn't work.

No - I don't have any other power manager software installed.

share|improve this question
    
Couldn't be a BIOS setting like in Dell laptops? –  Sneetsher Apr 9 at 22:13
1  
No. Macs don't have this. The behaviour doesn't happen when I'm booted into OSX. –  Terence Eden Apr 10 at 12:04
    
Are you using gnome or Unity or... Have you tried using any other environment? KDE, XFCE etc? (Not as a permanent replacement but to see what the problem might be). Will this occur if you boot the live CD and will this happen if you make a new installation? (you could install it on a USB) This could be useful information. –  Xweque May 6 at 9:24
    
have you tried caffeine as a temporary fix?? Install by typing sudo apt-get install caffeine in your terminal –  Arno van der Weijden May 6 at 9:24
    
also I believe there was a bug in 12.04 where the system didn't save the checkbox. You could try to check and uncheck it. That used to fix the problem. If you're using the gnome shell you could try running: xset s off ; xset s noblank ; xset -dpms ; In a terminal –  Arno van der Weijden May 6 at 9:26

2 Answers 2

You could try using caffeine as a temporary fix. You can install caffeine by running the following command in your terminal (Ctrl+Alt+T)

sudo apt-get install caffeine

To find a fix you could do the following things:

Run the following command in your terminal:

xset -q

If you see the energy saving settings enabled (DPMS is enabled) you'll need to disable it.

You can do that by running:

xset s off
xset s noblank
xset -dpms

This should stop the screen from dimming. xset -dpms doesn't survive a reboot so you can add the command to either /etc/rc.local or to ~/.xprofile.

If this doesn't work of xset -q shows you that the energy saving options are disabled comment and I'll try the next method I know


check /org/gnome/settings-daemon/plugins/power with dconf-editor to check that idle-dim-time is set to 600 and that the "active" checkbox is checked if this does not work uncheck the "active" checkbox.
if that does not fix your problem you probably have a alternative powersaving program installed and if you can discover what that other program is I might be able to help you.

If you don't have any other energy saving software installed could you check if a live dvd has the same issue? If it doesn't you are most definitely running some energy saving option that doesn't come out of the box. If it does have the same issue, there is only one thing I can think of that might work.

share|improve this answer
    
+1 because I was just about to suggest the same thing about caffeine. Aside from perhaps being a temporary fix (and a useful little app anyway), whether it works or not would indicate whether it was the normal Ubuntu dim-on-inactivity at work, or some different problem. –  Jon Hanna May 6 at 9:47
    
Indeed, if that doesn't work it could be a powersaving setting from some program like laptop-mode-tools. As far as I know (I haven't used caffeine in a long time) caffeine doesn't work on that sort of stuff –  Arno van der Weijden May 6 at 9:52
    
DPMS is disabled DPMS (Energy Star): Standby: 0 Suspend: 0 Off: 0 DPMS is Disabled –  Terence Eden May 6 at 11:56
    
Caffeine isn't available fo 12.04 and, furthermore, isn't suitable. I don't want to stop my screensaver - I want to stop the screen from dimming. –  Terence Eden May 6 at 12:01
    
Did you just disable DPMS or was it already disabled?? Caffeine is just a temporary fix to prevent that annoying dimming until a more suitable fix can be found. It can be installed on 12.04, you just need to add the repository sudo add-apt-repository ppa:caffeine-developers/ppaand update your system sudo apt-get update. After that you can install it with sudo apt-get install caffeine python-glade2 –  Arno van der Weijden May 6 at 12:53

There is this command with xbacklight, you could install this command and pick some infos from this link about a fujitsu-siemens-amilo-machine - assumed xbacklight is built-in in Apples Unix, you would not need to "re-animate" in Linux too ?! or ?!

LCD backlight keys on Fujitsu Siemens Amilo Pro

share|improve this answer
1  
Installing xbacklight and then running xbacklight -set 7 and xbacklight -time 500 seems to have worked! The screen doesn't dim :-) Thanks - and enjoy the bounty! –  Terence Eden May 12 at 21:29
    
@TerenceEden - thanks back ! now I need some computer-free time ... like you ... good night. sleep good. :) –  dschinn1001 May 14 at 21:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.