Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an ubuntu 13.10 and try to install wireshark on it. But I keep on getting the following error.

mininet@ubun_13_10:~/mininet$ sudo apt-get install wireshark
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-image-3.8.0-35-generic linux-image-extra-3.8.0-35-generic
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  wireshark-common
Suggested packages:
  snmp-mibs-downloader
The following NEW packages will be installed:
  wireshark
The following packages will be upgraded:
  wireshark-common
1 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/18.7 MB of archives.
After this operation, 75.9 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
(Reading database ... 318716 files and directories currently installed.)
Preparing to replace wireshark-common 1.10.2-1 (using .../wireshark-common_1.11.3+svn54990-0ubuntu1~saucy1~ppa0_amd64.deb) ...
Unpacking replacement wireshark-common ...
dpkg: error processing /var/cache/apt/archives/wireshark-common_1.11.3+svn54990-0ubuntu1~saucy1~ppa0_amd64.deb (--unpack):
 trying to overwrite '/etc/wireshark/init.lua', which is also in package libwireshark-data 1.10.6-1ubuntu2~ppa2~s
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Selecting previously unselected package wireshark.
Unpacking wireshark (from .../wireshark_1.11.3+svn54990-0ubuntu1~saucy1~ppa0_amd64.deb) ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for mime-support ...
Processing triggers for menu ...
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/wireshark-common_1.11.3+svn54990-0ubuntu1~saucy1~ppa0_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
mininet@ubun_13_10:~/mininet$ 


mininet@ubun_13_10:/etc/init.d$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=13.10
DISTRIB_CODENAME=saucy
DISTRIB_DESCRIPTION="Ubuntu 13.10"
mininet@ubun_13_10:/etc/init.d$ 

What should I do to resolve the above error?

share|improve this question
    
Please upgrade to 14.04, 13.10 ends it life today... –  ARUL Jul 31 at 4:30

1 Answer 1

Please try the following commands: (It worked for me with Ubuntu 12.04)

sudo dpkg --force-all -i /var/cache/apt/archives/wireshark-common_1.11.3+svn54990-
0ubuntu1~saucy1~ppa0_amd64.deb

sudo apt-get install wireshark
share|improve this answer
    
Welcome to AskUbuntu! You may want to explain the commands to improve the answer. (Such as you are downloading from Saucy PPA) –  No Time Jul 31 at 4:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.