Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I run ubuntu 12.04. Recently, I have followed this post and updated GCC to 4.8.1. Now, when I compile with g++, I get compiler output like these:

/usr/include/c++/4.6/bits/stl_algobase.h:743: note:   Profitability threshold = 6
/usr/include/c++/4.6/bits/stl_algobase.h:743: note: Profitability threshold is 6 loop iterations.
/usr/include/c++/4.6/bits/stl_algobase.h:743: note: LOOP VECTORIZED.

My question is why is g++ using the STLs from GCC 4.6? Is this normal or does this show that I didn't updated GCC thoroughly? If the latter, how can I direct g++ to the new STLs?

Edit0: i installed package g++-4.8 (just now, thanks steeldriver) but still get the same messages~

Edit1: I followed kenn's suggestion and just ran sudo ldconfig...but I still get those messages

Thanks in advance,

share|improve this question
1  
Did you also update g++? –  steeldriver Apr 2 at 19:51
1  
did you run sudo ldconfig after installation of gcc? –  kenn Apr 2 at 20:11
    
Check with which g++ for the path and see if it's the right path –  arsaKasra Apr 2 at 20:21
    
@arsaKasra; thanks! but how do I do that? –  user2413 Apr 2 at 20:23
    
don't confuse gcc with g++ –  kenn Apr 2 at 20:38
show 3 more comments

1 Answer 1

up vote 0 down vote accepted

OK, I've answered my question by combining these two answers to related quetions. answer 1: update g++ to g++4.8

answer 2: create new Symlinking

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.